Previous 1 2 3 Next 66 Replies Latest reply: Oct 16, 2014 3:07 AM by garlicbatman
DJSamHiller Level 1 Level 1 (0 points)

Ever since I upgraded to Mavericks, my 13 inch MacBook Pro (2010) isn't able to Index my Western Digital My Passport External Hard Drive.  It just keeps saying "Indexing" and "Estimating Indexing Time," but never seems to start or finish, even when left running overnight.  I really need to be able to search my hard drive using Spotlight for work, so this is quite an inconvinience for me. When I type in a search phrase in Finder the related files sometimes appear, but when they do they constantly flash on an off, as if it's finding them but then losing them again.

 

I haven't suffered any data loss as other WD user seem to have, so that's good, but I really do need to solve this indexing problem.

 

Please help!


MacBook Pro, OS X Mavericks (10.9)
  • arthur Level 5 Level 5 (4,880 points)

    It's probably because of the WD software that's on the drive.

    I'd copy the files to another (non-WD) drive, erase that drive, uninstall any WD "utilities" that are on your internal drive, and then put the files back on your WD. Then the indexing will work.

  • DJSamHiller Level 1 Level 1 (0 points)

    So there's likely no way to solve this problem without buying another drive to move my data to? (I dont have a spare lying around.) Shouldn't Apple at some point release an update or fix that solves all of these people problems people with WD drives have been having?

  • tbirdvet Level 4 Level 4 (2,380 points)

    I suspect it is WD responsibility to fix their software and not Apple.

  • DJSamHiller Level 1 Level 1 (0 points)

    How would I delete said utilities? 

     

    I just discovered that a SanDisk thumb drive of mine also won't index, and it has less than 1 GB of stuff on it.  So my problem doesn't seem to be with WD products and Mavericks, but with Mavericks and indexing external drives in general?

  • arthur Level 5 Level 5 (4,880 points)

    I'd look for an uninstaller on the WD website, or google it. Don't know about the flash drive issue.

  • pbandnv Level 1 Level 1 (10 points)

    I'm having the same problem, also have a WD External HD has been endlessly trying to index in spotlight since I upgraded to Maverick. I totally disagree that this is a WD problem. Apple used to flaunt how "compatible" their computers are with other devices-- remember the comercials of Windows users having to scoure the web for updates and drivers, while the Mac user just plugs in a device that works seemlessly? Apple dropped the ball on this one and needs to fix it pronto in my opinion. I should not be expected to by new devices everytime OSX comes out with an upgrade. I call BullS@#t on this one.

  • nirurin Level 1 Level 1 (0 points)

    "I suspect it is WD responsibility to fix their software and not Apple."

     

     

    I would just like to join this discussion, as I am having the exact same issue with my new external drive. Mine is not a WD though, it is a Buffalo drive (which i think is actually a seagate drive inside).

     

    There is no pre-installed software on the drive, it is totally formatted for the mac.

     

    The problem is definitly with the OS, not the drive itself, and it is Apple who have totally dropped the ball on this.

     

    At the moment the only solution is to set up a series of terminal commands in applescript, (or you can enter them manually each time) to wipe the spotlight index from the drive. You will have to do this every day or two.

     

    It is not an ideal solution, and I am hoping apple ends up actually fixing this.

     

    Just to help you out in case you want to go this route, the terminal commands are:

     

    sudo mdutil -i off /Volumes/'name of your drive'

    sudo mdutil -E /Volumes/'name of your drive'

    cd /Volumes/'name of your drive'

    sudo rm -fr .Spotlight-V100

    sudo mdutil -i on /Volumes/'name of your drive'

     

     

    If you have any problems, I'll try and help. I would put links to the forum where I sorted this solution, or the places where I got this answer from, but I dont think I'm allowed to post links to other sites on here... if I'm wrong let me know and I'll put up the links.

     

    Hope this helps!

  • DJSamHiller Level 1 Level 1 (0 points)

    This also worked for me, and seems to be a quicker fix than the one listed above.  Not sure if it's a do once permenant solution, but it did get my computer to start indexing my drives:

     

    "Go to Spotlight preferences and into Privacy, add your hardrive to the list where you don't want Spotlight to search, then remove it, and Spotlight would begin the correct index and state a time."

  • pbandnv Level 1 Level 1 (10 points)

    This seems to be working for me as well : "Go to Spotlight preferences and into Privacy, add your hardrive to the list where you don't want Spotlight to search, then remove it, and Spotlight would begin the correct index and state a time." Thanks to the person who discovered this. So far it's been three days without a problem. But, I have not rebooted my iMac or disconnected the drive in this time... not sure what will happen if I do.

  • nkiyer65 Level 1 Level 1 (0 points)

    Thanks DJS. Problem solved.

  • DJSamHiller Level 1 Level 1 (0 points)

    Every time I eject my external drive and plug it back in I have to do this whole process again.  So it's a fix, but not a good fix :/

  • nirurin Level 1 Level 1 (0 points)

    This is why the "Adding and removing drive from spotlight privacy" solution was never actually a fix, cos it doesnt work past a reboot or a disconect/reconnect.

     

    My solution does seem to work past a reboot, but it only lasts a few days at best before the problem comes back again.

  • Cat Songs Level 1 Level 1 (25 points)

    Thanks!

     

    Been surfing discussions here there and everywhere today... as my CPU got gobbled up and my temperature readings went off the chart...

     

    Your solution WORKED!

     

    Can't thank you enough!

     

    Cheers,

     

    Cat

  • xmiller Level 1 Level 1 (0 points)

    Will Wd or Apple be paying for all the people's recovery of data?

Previous 1 2 3 Next