14 Replies Latest reply: Apr 10, 2014 11:34 AM by g.p.fromnld
ad_marta Level 1 Level 1 (0 points)

Hello,  

 

I have a MacBook Pro connected to Internet through AirPort Express with a Thunderbolt Ethernet cable. I am living in halls of residence, so I do not own a router.  Before upgrading to Mavericks, my All-in-One printer (Epson XP-305) was working properly and wirelessly through the Airport Express. After the OS upgrade, both functions (printer and scanner) stopped working. 

 

Once the new drivers were available, I installed both successively to make the XP-305 fully compatible with Mavericks. 

 

Now, my printer is working fine, but I have not been able to use the scanner anymore. It seems not to be detected, neither if I introduce manually the IP address that is used by the printer. 

 

The only way I can scan is by turning my MacBook's Wi-Fi on, which is not what I really want, because I need the wi-fi access through the Airport for all my devices, including e.g. my iPhone. 

 

Why is this happening? 

 

Do I have to manually change something on my AirPort configuration? 

 

When looking at AirPort Utility settings (version 6.3.2), it says there is an update available. Is this update going to solve the problem? 

 

Thanks in advance,  

 

Marta


MacBook Pro (Retina, 13-inch, Early 2013), OS X Mavericks (10.9)
  • 1.
    sheila_m. Community Specialists Community Specialists (3,245 points)

    Hello Marta,

     

    Thank you for the details of the scanning issue you are experiencing.  I looked at the printer list "Printer and scanner software available for download" (http://support.apple.com/kb/HT3669), and the Epson XP-305 was listed as a compatible printer and scanner.

     

    Even though it is compatible, it sounds like you are not able to scan from your Epson XP-305.  I found an article with steps you can take to troubleshoot printer and scanner issues on a Mac:. 

    Follow these steps until the issue is addressed:

    1. Make sure that the printer is powered on, has ink / toner, and that there are no alerts on the printer’s control panel. Note: If you cannot clear an alert on the printer's control panel, stop here and check the printer's documentation or contact the manufacturer for support.
    2. Ensure the printer is properly connected to a USB port on the Mac or AirPort base station / Time Capsule. If the printer is a network-capable printer, make sure that it is properly connected to your home network.
    3. Use Software Update to find and install the latest available updates. If an update is installed, see if the issue persists.
    4. Open the Print & Scan pane or Print & Fax (Snow Leopard) pane in System Preferences.
    5. Delete the affected printer, then add the printer again.
    If the issue persists, try these additional steps:
    1. Reset the printing system, then add the printer again.
    2. If the issue still persists, reset the printing system again.  Download and install your printer's drivers. Then, add the printer again.
    3. Contact the printer vendor or visit their website for further assistance.

    Additional Information

    Note: If your printer is wireless-capable, you should first add the printer to your network. Use the printer's control panel, or temporarily connect the printer to your Mac via USB.  For more details, see this article.

     

    You can find the full article here:

    Troubleshooting printer issues in OS X

    http://support.apple.com/kb/TS3147

     

    Thank you for using Apple Support Communities.

     

    Best,

    Sheila M.

  • 2. Re: Scanner not working after Mavericks upgrade
    John-Hull-UK Level 1 Level 1 (0 points)

    I had exactly the same issue, there is a newer update on the epson site that you need to install (16/11/13) Install latest package, but you just need to choose network printer and add the xp-305 to the trusted list and test, all should be fine once you add it.

     

    This was my setup, xp-305 using Maverick. Mine is 100% now, but you will definitely need the latest update from Epson

     

    This is the page>> http://www.epson.co.uk/gb/en/viewcon/corporatesite/products/mainunits/support/11 536

     

    This is the package>>

    EPSON Scan (v3.792) 29-Oct-2013

  • 3. Re: Scanner not working after Mavericks upgrade
    ad_marta Level 1 Level 1 (0 points)

    Thanks, John. I already installed the new Epson Scan driver, but it didn't work. But what do you exactly mean by "choose network printer and add the xp-305 to the trusted list and test"? I might have done it before as well, but I'm not sure.

     

    Thanks in advance,

     

    Marta

  • 4. Re: Scanner not working after Mavericks upgrade
    John-Hull-UK Level 1 Level 1 (0 points)

    Hi. When you run the package and then the scanner program you get presented with local or network as one of the options. Choose network and click on the add printer above the radio button. Your Xp-305 should auto populate, what I mean by accept/trust it is to click ok really, then go to apps and preview a scan it should be ok, if not uninstall the printer and reinstall it. It will work with this update

  • 5. Re: Scanner not working after Mavericks upgrade
    Johnny Bates Level 1 Level 1 (0 points)

    I had the same problem with my Epson RX520 all-in-one ... prints OK but scanner didn't work. 

     

    I'm not an expert but have used Macs for eight years ... so try this!  Plug your printer USB into your Mac, switch on the printer and go to Mac's "Image Capture" which can be found in your Applications list (it looks like a little camera icon)... your scanner should appear here with all the usual options.  It worked for me and mine now scans beautifully.

     

    Another option is to plug in the printer, turn it on and go to the Apps store ... click on the "updates" tab at the top, your printer may well be listed there with the Apple software which replaces the original Epson.

     

    Hope this helps ... good luck!

    Johnny B

  • 6. Re: Scanner not working after Mavericks upgrade
    Eddu Vaz Level 1 Level 1 (5 points)

    i have a problem here i work with 2 printer on wifi other by bluetooth but if the mac goes on sleep mode dont find the wifi printer, i have to shutdown the notebook e star again

  • 7. Re: Scanner not working after Mavericks upgrade
    olebols Level 1 Level 1 (0 points)

    I have the same problem, except I have a Canon Pixma MP280 printer/scanner. I have recently updated my Mac Pro to OSX Maverics, and despite having installed the newest scanner driver, I can only get the print function to work. The scanner freezes up while the lamp is warming up..

     

    The printer/scanner is plugged in through USB. Oddly, I can get the scanner to work on my older MacBook Pro, which also has Maverics installed..

  • 8. Re: Scanner not working after Mavericks upgrade
    Dee33k Level 1 Level 1 (0 points)

    My scanner worked with the NEW update from Apple  until Feb 2nd, when, as I understand it, another update for iphoto came out.  I now cannot get anything to scan past the overview or through image capture.

     

    Plugged in through usb.  Had been working very well.  In the middle of a huge project.

     

    Brand new imac with mavericks.

     

    This is getting old pretty quickly.

  • 9. Re: Scanner not working after Mavericks upgrade
    gentux Level 1 Level 1 (0 points)

    Pretty much the same problem here with Epson WP-4540, even though the scanner is detected, it says "Waiting for scanner..." all the time, no scanning possible.

     

    I've tried Epson Scan then, it previews, then scans, then nothing for 5 minutes but the fans at 100% and then "network communication terminated"! This machine was working very fine with every OS X I had before and it copies and prints as expected so this is clearly an OS X issue!

     

    It seems to me, that Apple is no longer interested in making good products but good profit not with good products but with a thing that was a great brand before. I'll certainly not buy anything from Apple anymore!

  • 10. Re: Scanner not working after Mavericks upgrade
    Eric Root Level 6 Level 6 (16,210 points)

    It is Epson's responsibilty to update their drivers, not Apple's.

  • 11. Re: Scanner not working after Mavericks upgrade
    TamyMom Level 1 Level 1 (0 points)

    Since updating to os x mavericks 10.9.2 my macbook pro will no longer detect my hp photosmart c7250 all-in-one printer.  I have tried everything i can think of to rectify this problem.  From the comments on this board it seems there are many others with similar issues.  Does anyone know when apple will be adding a fix for this problem?

    Thanks-

  • 12. Re: Scanner not working after Mavericks upgrade
    tbirdvet Level 4 Level 4 (1,230 points)

    Did you try downloading 10.9 drivers from the HP site?  That is what I had to do for my HP6525 printer.

  • 13. Re: Scanner not working after Mavericks upgrade
    kent218 Level 1 Level 1 (0 points)

    Have read all of these. I have a beautiful Canon 9950F, hardly used. Been through all of the links suggested above. I am running 10.9.2  Mavericks on an iMac. Everything here - links, Apple, other sites - all indicate...crap! Am i ...up **** creek without a paddle?

     

    Does the Epson v750 work?

  • 14. Re: Scanner not working after Mavericks upgrade
    g.p.fromnld Level 1 Level 1 (0 points)

    This is a very nasty problem. Thanks very much for the solution you provided.
    Image Capture scans my Epson SX 525 now.