8 Replies Latest reply: Nov 8, 2013 1:49 PM by dragonsoul2
dragonsoul2 Level 1 (0 points)

Hello everyone,

 

I just upgraded to FCP 7. I did the entire installation, and in the end it said that the installation was successful. So I go to launch it, get the Easy Setup pop-up, set my choices, then FCP starts loading again, but then crashes. This occurs EVERY time and I have no idea why. I have the crash report, so I can post any necessary info here that you'll need, just let me know what that is. Please help me, I would greatly appreciate it.


Final Cut Pro 7, Mac OS X (10.7.5)
  • Meg The Dog Level 6 (10,880 points)

    Use Disk Utility to repair your permissions.

    Then download Preference Manager from Digital Rebellion (free) and use it to trash your FCP preferences. They will be set to default the next time you launch FCP.

     

    http://www.digitalrebellion.com/prefman/

     

    MtD

  • dragonsoul2 Level 1 (0 points)

    Thank you so much for your prompt reply and suggestions. I repaired permissions through Disk Utility and then trashed preferences through Preference Manager, but FCP still crashes upon launch. This is the first part of the crash report:

     

    Process:         Final Cut Pro [202]

    Path:            /Applications/Final Cut Pro.app/Contents/MacOS/Final Cut Pro

    Identifier:      com.apple.FinalCutPro

    Version:         7.0 (7.0)

    Build Info:      FCPApp-906181654~22

    Code Type:       X86 (Native)

    Parent Process:  launchd [127]

     

     

    Date/Time:       2013-11-07 21:12:37.390 -0600

    OS Version:      Mac OS X 10.7.5 (11G63)

    Report Version:  9

     

     

    Interval Since Last Report:          199346 sec

    Crashes Since Last Report:           9

    Per-App Interval Since Last Report:  173 sec

    Per-App Crashes Since Last Report:   9

    Anonymous UUID:                      5E9F31BF-2658-44E7-8ED6-A30E94180709

     

     

    Crashed Thread:  0  Dispatch queue: com.apple.main-thread

     

     

    Exception Type:  EXC_CRASH (SIGABRT)

    Exception Codes: 0x0000000000000000, 0x0000000000000000

     

     

    Application Specific Information:

    objc[202]: garbage collection is OFF

    abort() called

    terminate called throwing an exception

     

     

    Can you recommend any other solutions?

  • Michael Grenadier Level 7 (20,340 points)

    Digital Rebellion has a crash analyzer

     

    http://www.digitalrebellion.com/promaintenance/

     

    Not the cheapest thing, but a great suite of apps.  There's a trial avaialble, so download and check out what's causing the crash and then post back.

  • dragonsoul2 Level 1 (0 points)

    Ok, so I downloaded Pro Maintenance, and ran the Crash Analyzer. It says my crashes were cause by "Corrupt Qmaster Configuration" and recommended I run Compressor Repair, which I did, and these were the results:

     

    Detected Compressor 3.5.x.

     

    Stopping Qmaster...

     

    Trashing preferences...

     

    Resetting window layout...

     

    Checking file permissions...

     

    /Applications/Utilities/Batch Monitor.app is not writable... attempting fix.

     

    /Library/Application Support/Apple Qmaster is not writable... attempting fix.

     

    /Library/Application Support/Apple Qmaster/qmasterservices.plist is not writable... attempting fix.

     

    /Library/Application Support/Apple Qmaster/qmasterconfig is not writable... attempting fix.

     

    Removing caches...

     

    Removing temporary spool data...

     

    Clearing history...

     

    Checking computer name...

     

    Attempting to start Qmaster...

     

    Relaunching menu bar icon...

     

    Processing complete. Errors were found during processing.

     

    I'm wondering if somehow, whatever this Qmaster thing is was deleted or moved?

  • Michael Grenadier Level 7 (20,340 points)

    can you open the qmaster panel in system preferences?  And have you tried running fcp7 since running compressor repair?

  • dragonsoul2 Level 1 (0 points)

    Yes, I am able to open Qmaster in System Preferences. And did try running FCP after doing Compressor Repair, the crash still occurs.

  • Michael Grenadier Level 7 (20,340 points)

    what OS are you running? 

  • dragonsoul2 Level 1 (0 points)

    I'm running Mac OS X (10.7.5)