Previous 1 2 3 Next 170 Replies Latest reply: Jan 7, 2015 11:31 AM by Smithy9999
Reforger Level 1 Level 1 (0 points)

I've created this as a new thread as it seems to be more prevalent with Mavericks and the very last update to ML but the problem has been around a while. It does seem to affect all types of Mac though from the other threads I have read and posted to.

 

The problem is essentially this: Intermittently, after a system sleep, the Mac appears to have no network connectivity (local and internet) and for a while the only reliable solution was to force the renewal of the DHCP lease or turning WiFi off and on again, after which the network would be restored.

 

There have been several theories postulated and a number of fixes, such as the DHCP renew, suggested but none of them have lasted for long but I now think I have this fixed as the following been 100% stable on my Mac Pro with wired ethernet connection for the last two weeks with no recurrences. I see no reason why this would not work on other Macs or connection types.

 

The problem seems to lie in the automatic location setting in the network settings, so here's what I did...

 

  1. Network settings - Location - Edit Locations
  2. Add a new location .. "Home" for example
  3. With home selected, click the cogwheel below the network services and choose "Set Service Order"
  4. Reorder the services so your preferred connection type is at the top
  5. After that, select each service in turn (assuming you have a few - like Bluetooth PAN etc)
  6. Make the services you are not using inactive
  7. Apply

 

Please post a reply if this works for you - it's been dragging on far too long and needs sorting out by Apple but if this is a good workaround for people then it will certainly do for now.


Mac Pro (Mid 2010), OS X Mavericks (10.9)
  • MHTSOSMAN Level 1 Level 1 (0 points)

    It worked ! Thank you very much for the solution! I managed at last to back up to time machine. I have a mac pro early 2008 and every time i started a back up the network connection dropped and put me to a self assigned IP.

     

    I spent 2 days to find a solution and finally worked!

     

    Thank you again

  • ki11a Level 1 Level 1 (0 points)

    Works great...I have been having this same problem since Lion and was wondering what was up with it; upgraded to Mavericks and still had the same issue so I went to the forums for help.

     

    My WIFI would just randomly crash and not be able to connect until I turned it off and back on, I have tried every other solution including resetting the DHCP and resetting the Airport but none of those worked.

     

    I created this account just for saying Thank you for posting this.

  • thomasfromstolberg Level 1 Level 1 (0 points)

    can anyone explain this in german? Thanks

  • MarkH356 Level 1 Level 1 (30 points)

    Network Prefs.jpgMy German is nicht sehr gut. Perhaps this image might help explain.

  • mrsannmc Level 1 Level 1 (0 points)

    I've had this problem intermittently on my iMac for years now but this is the first time I've ever googled the problem and I feel much better knowing it's so common.

     

    I've decided to chip in to say that I've always been able to regain the ethernet connection after sleep by simply pulling out and reinserting the ethernet cable at the back of the iMac. It's a bit of a pain but a lot quicker than the rebooting some others were mentioning.

     

    The "new location" solution above looks good but as a lone female tech-phobic user I'm always reluctant to mess with anything for fear of making it worse and the "cable out, cable in" solution has served me well for several years now.

  • MHTSOSMAN Level 1 Level 1 (0 points)

    The new location solution is great and harmless , you should do it.

  • scottfitzroy Level 1 Level 1 (0 points)

    I tried to perform this by creating a new location from the drop down, it worked and stayed onnected after sleeping/closing for exactly one day, then reverted back to its searching for the network in vain. The wifi is at the top of the service order selections for all locations, but every time it sleeps it loses the connection and the network name menu goes blank, I have to manually choose it each time and apply. Help!

  • thomasfromstolberg Level 1 Level 1 (0 points)

    Thank you, i tryed it. But it works not long. Today the Connection is faild again. Hmm

  • m@rk_o Level 1 Level 1 (0 points)

    Have a 2oo9 Macbook Pro and after updating to Mavericks from Snowleopard WLAN stopped working or at least it works badly, i.e., network is not found after boot or is dropped after sleep. Also, my router is not, most of the time, shown in the list of available networks (yet, others are shown).

     

    Called Apple support today. They told me to delete the folder //Library/Preferences/SystemConfiguration. At least now it looks like it solved the problem. Skeptic, though.

  • scottfitzroy Level 1 Level 1 (0 points)

    Thomas: the same thing is happening to me it seems, there are other threads with this same Mavericks problem. I have contacted applecare they have been looking into it for over two weeks and their engineers have not come up with any fix yet, but the file is open. I will keep people posted but any other ideas? m@rk I also deleted the systemconfirguration file upon your advice but no luck, it didn't work...

  • ki11a Level 1 Level 1 (0 points)

    Seeing as many people have this problem, it also seems to be a mix of router problems. Changing the wifi password encryption to WPA2 personal also fixed this problem.

  • scottfitzroy Level 1 Level 1 (0 points)

    I just tried that also and after it dropped it still could not reconnect - the network name always defaults to blank, it is never there if I check the network afterwarsd, I have to manually re-enter the wifi name and apply...

  • MarkH356 Level 1 Level 1 (30 points)

    Following Reforger's advice didn't cure my network dropping out problem completely, but it did significantly reduce the frequency with which I have to turn wireless off and back. Similarly, waking from sleep now reconnects about 50% of the time whereas before it was zero.

    The only things I have found that are completely effective at preventing the drop outs with Mavericks is (a) use an Apple Airport Extreme router or (b) setup your non-Apple wireless router to only use 801.11g as it seems to be 801.11n that Mavericks struggles with. My router at home has both an "n" channel and a guest "g" channel. I don't get any drop outs when I connect via the guest channel, but do when trying to use the faster "n" channel.

  • Reforger Level 1 Level 1 (0 points)

    I probably should have added that I had the same network issues both after an upgrade from Mountain Lion to Mavericks and then again after a full clean install from scratch so that, for me, blew away any notion that this was due to some lingering config files or other bits of junk left over from a previous OS.

     

    In response to mrsannmc, the cable in/out method has the same effect as forcing a DHCP renew - which would also bring back the network connection (as does turning WiFi off & on) in my experience.

     

    However, in light of everything above, the solution I outlined in the original post has been 100% successful, both on my Mac Pro wired connection and also on a 2009 MacBook running a Mavericks upgrade from ML, which has totally cured the need to switch WiFi on & off.

     

    For MarkH356 I think there may be a compounded issue with the compatibility of your router. I'm using an Asus RT-N66U and the MacBook is now absolutely rock solid on 802.11n at 5Ghz.

     

    Clearly I can't address every case but I remain convinced that the problem lies with the automatic network location feature.

Previous 1 2 3 Next