Previous 1 2 Next 15 Replies Latest reply: Feb 2, 2016 6:32 PM by Nadjia
PGAdams Level 1 Level 1

Since upgrading to Mavericks, my Gmail accounts have been acting up in my Mac Mail program. At first it was just extremely slow to download the IMAP mail (my other POP email accounts continue to work just fine). However, in the past couple of days, I've noticed that incoming mail through the Gmail account randomly goes to my Inbox or to the Archive folder. This is very frustrating and can lead me to missing emails that I need to see. I haven't changed any settings in Gmail or in the Mac Mail program.

 

I have had no problems in continuing to recieve messages correctly on my iPad and iPhone, however.

 

Does anyone have any suggestions on how to fix this? I've found some information posted about this problem but there are multiple suggested "fixes" and I'm not sure which one(s) might really work and what possible negative impact they might have.

 

Any idea when Apple will have a fix for this?

 

Thanks.


MacBook Pro (15-inch Early 2011), OS X Mavericks (10.9)
Reply by TPIRman on Nov 8, 2013 10:39 PM Helpful

Hey PGAdams, I fixed this problem by going to my Gmail Settings > Labels and unchecking the "Show in IMAP" checkbox next to "All Mail." Hopefully, this will work for you, too!

Reply by TPIRman on Nov 8, 2013 7:06 AM Helpful

The Mail Update For Mavericks actually caused this problem for me. Before the Mail Update, my Gmail behavior was weird and half-broken like a lot of other people's. After the Update, it's just now completely broken—all new mail is instantly shunted out of the inbox and into Archive. Idiotic.

All replies

  • dustda01 Level 1 Level 1

    Hi PGAdams.

     

    Apple released a fix to Mail today that supposedly fixes compatibility with Gmail accounts.

     

    Get it through the App Store update page or at http://support.apple.com/kb/DL1703 - "Mail Update for Mavericks". Details of the update are found at http://support.apple.com/kb/HT6030.

     

    Not sure if this will fix the exact problem you are experiencing, but may as well try it. I hope it helps.

  • TPIRman Level 1 Level 1

    The Mail Update For Mavericks actually caused this problem for me. Before the Mail Update, my Gmail behavior was weird and half-broken like a lot of other people's. After the Update, it's just now completely broken—all new mail is instantly shunted out of the inbox and into Archive. Idiotic.

  • TPIRman Level 1 Level 1

    Hey PGAdams, I fixed this problem by going to my Gmail Settings > Labels and unchecking the "Show in IMAP" checkbox next to "All Mail." Hopefully, this will work for you, too!

  • Melinda S. Level 1 Level 1

    Thanks for the tip, TPIRman. That did the trick for me as well. All the messages that had been moved to the All Mail Archive folder reappeared in my inbox after changing that setting.

  • TPIRman Level 1 Level 1

    Cool! Glad I could help out.

  • alex_sz69 Level 1 Level 1

    Thanks TPIRman, that worked for me and 4 other acounts too! finally that is solved! Appreciate your input on that subject.

  • hepcat72 Level 1 Level 1

    I wonder if this was catalyzed by my call to Apple yesterday complaining about this very issue!

  • Susan Gutterman Level 1 Level 1

    I am having this problem, too.  Where do I find "Gmail Settings"?

  • Susan Gutterman Level 1 Level 1

    I think I answered my own question.  Found it when I went directly to my Google account.

  • gavlaw1 Level 1 Level 1

    Brilliant to finally have an answer to this issue and such a simple fix too!!!

     

    Thank you

  • Erikamarie10 Level 1 Level 1

    This fix worked really well! After unchecking the box next to archive in Labels, and then restarting mail, I get my emails in the inbox again. TPIRman you saved my computer's life! (seeing as I was about to chuck it across my coffee table)

     

    Thanks!

  • jennbcreamer Level 1 Level 1

    Thank you so much TPIR man I thought I was going crazy. Such an easy fix.

  • dgeastty Level 1 Level 1

    I ditto all the folks above!  I have been searching for days for a solution to this.   There is no way I would have looked under "labels" in gmail.  And even if I did, I wouldn't have known what to do.   By following your instructions I now know I am not crazy!  I don't know how long all my email has been going to Archive - but I noticed it after upgrading to Mavericks.    And when one of my gmail accounts went "offline" due to the size of the Archive.    So I still have that issue.

     

    What happened when all my emails were going to Archive - one of my accounts met a space limit and apple mail has taken the account offline.   When I ask for "Account Info" within Apple mail this is the error I get "This account is offline.  The totals above may be inaccurate."  The size of the archive for this mailbox is 82.9MB.       Is there a way to delete the archive?    I tried exporting the mailbox, but that didn't seem to work either.

     

    Any suggestions would be welcome!  Thanks.

  • bhelmick Level 1 Level 1

    Well, all of you guys may like this suggestion re unchecking the "Show in IMAP" box for All Mail.  This is a suggestion a lot of techs used to recommend prior to Mavericks, but just remember that if you do that, then while you will have access to your All Mail folder on the gmail web interface, from within your Mac Mail,  your Archive folder for that account will disappear and you will lose local access to same.

Previous 1 2 Next