4 Replies Latest reply: Dec 12, 2013 12:13 PM by Mario1949
Mario1949 Level 1 Level 1 (0 points)

Since updating to Mavericks, Safari hangs when asked to navigate to another page.  The rainbow wheel just goes round and round...  Eventually, Force Quit will change to Not Responding. 

 

Three variations of the prevalent error message follow:

 

11/7/13 12:54:30.795 PM Safari[435]: could not create "/Users/PowerMac/Library/Caches/com.apple.Safari", error Error Domain=NSCocoaErrorDomain Code=513 "You don’t have permission to save the file “com.apple.Safari” in the folder “Caches”." UserInfo=0x60800047ee40 {NSFilePath=/Users/PowerMac/Library/Caches/com.apple.Safari, NSUnderlyingError=0x60800025e510 "The operation couldn’t be completed. Permission denied"}

 

 

11/7/13 9:57:20.576 PM Safari[2258]: [AOSAccounts] : [IsAccountKeyChainActive] : had error: The operation couldn’t be completed. (com.apple.security.sos.error error 2 - Remote error : The operation couldn‚Äôt be completed. (com.apple.security.sos.error error 2 - Public Key not available - failed to register before call))
11/8/13 3:31:43.863 PM Safari[803]: could not create "/Users/PowerMac/Library/Caches/com.apple.Safari", error Error Domain=NSCocoaErrorDomain Code=513 "You don’t have permission to save the file “com.apple.Safari” in the folder “Caches”." UserInfo=0x7fcc4b0caf00 {NSFilePath=/Users/PowerMac/Library/Caches/com.apple.Safari, NSUnderlyingError=0x7fcc4b0bd680 "The operation couldn’t be completed. Permission denied"}
Any help will be greatly appreciated!

Safari, OS X Mavericks (10.9)
  • Carolyn Samit Level 10 Level 10 (96,750 points)

    Try troubleshooting Safari extensions and third party plugins.

     

    From the Safari menu bar click Safari > Preferences then select the Extensions tab. Turn that OFF, quit and relaunch Safari to test. If that helped, turn one extension on then quit and relaunch Safari to test until you find the incompatible extension then click uninstall.

     

    If it's not an extensions issue, try troubleshooting third party plug-ins.

     

    Back to Safari > Preferences. This time select the Security tab. Deselect:  Allow all other plug-ins. Quit and relaunch Safari to test.

     

    If that made a difference, instructions for troubleshooting plugins here.

     

     

    And delete the Safari cache.db

     

    Open the Finder. From the Finder menu bar click Go > Go to Folder

     

    Type or copy paste the following:

     

    ~/Library/Caches/com.apple.Safari/Cache.db

     

    Click Go then move the Cache.db file to the Trash.

     

     

    Quit and relaunch Safari to test.


     


     


  • ergoboard Level 1 Level 1 (0 points)

    I've no doubt that it's good advice, but my faster solution is to switch to a browser that works - in this case Firefox - if that can work within Mavericks, why can't Apple get it right for their own product?

  • Mario1949 Level 1 Level 1 (0 points)

    I did as you suggested and discovered that  Adobe Flash Player seems to be the problem.  I am presently trying to figure out why.  If anyone has suggestions, I'd appreciate them.

  • Mario1949 Level 1 Level 1 (0 points)

    Yes, as a temporary fix, I used Firefox to access any sites requiring Flash Player.  Unfortunately, I have other problems trying to use Firefox so it's not a total solution for me.