0 Replies Latest reply: Nov 8, 2013 5:52 PM by NateFurman7
NateFurman7 Level 1 Level 1 (0 points)

Hey guys, so basically my friend asked me " why is all your messages coming from your email? " so I looked into it and basically iMessage is sending all of my messages through my emails instead of my phone number.


When I go to settings>messages>send and recieve> my phone number is greyed out and I can't select it.


I turned off iMessage and turned it back on and now its stuck at "waiting for activation".


I dont really want to have to reset all my networks settings because I have a lot of wifi passwords in there lol.


So my question is, what could I do so that my iMessage will send texts through my mobile number instead of my email?

How do I fix this? Any and all help is appreciated, thank you!

iPhone 5