Previous 1 2 3 Next 32 Replies Latest reply: Dec 22, 2015 9:49 AM by jgbivona
Julian Bashir Level 1 Level 1

Hello All,


I just purchased an iPad Air 128Gb Wi-Fi version to replace my iPad 2 64 Gb Wi-Fi version. I tried to restore the iPad Air with the iPad 2 backup through iTunes, but each time it aborts with a message to effect that the iPad 2 backup is either corrupted or not compatible. I tried backing up the iPad 2 again and then restoring iPad Air with the newer backup - but get the same message.


The result of this is that it is trying to sync all my old Apps but without their data - i.e. no previous game saves and the like. It also is not maintaining the folder structure that I previously had on my iPad 2.


Is there some kind of compatibility problem with restoring from an iPad 2 backup? This seems strange since my iPad 2 is only 2 years old. I've seen that other people had similar problems but with different devices. I'm just wondering if anyone has had this problem trying to restore to an iPad Air from an older iPad backup, and how do you get around this problem?


Any help would be tremendously appreciated. I really need to get my old App data and App folder structure from the old iPad backup.


FYI, I made sure that both the iPad 2 and the iPad air are both using iOS 7.0.3 in case that matters.

iPad Air Wi-Fi, iOS 7.0.3
Reply by Diavonex on Nov 8, 2013 9:57 PM Helpful

Have you tried restoring from iCloud Backup?

All replies

  • Diavonex Level 9 Level 9

    Make sure your iPad Air is running IOS 7.0.3 before you restore.

  • Julian Bashir Level 1 Level 1

    As I had indicated, they are both using iOS 7.0.3.

  • Diavonex Level 9 Level 9

    Have you tried restoring from iCloud Backup?

  • Alfred DeRose Level 5 Level 5

    Check that you are running the latest version of iTunes as well.

  • Julian Bashir Level 1 Level 1

    I am running the latest version of iTunes. I do not normally back up my iPad to iCloud because I use iCloud for iPhone backup, and 4/5 Gb have been used. However, I tried checking the option to backup to iCloud for the iPad, and for some reason it isn't working.

  • Julian Bashir Level 1 Level 1

    It looks like restoring from iCloud backup is working, after multiple failed attempts to get my iPad 2 to backup via iCloud.


    I'm still not sure why it would not restore from the iTunes backup. I may not want to continue using iCloud forever as a backup solution. Today I was having multiple problems with the devices being able to connect to the server. Also, there are dead zones where Wi-Fi does not work in my house. I'm also not clear on why 4 out of my 5 Gb iCloud storage allowance has been used up, when the the backups themselves are no more than 500-800Mb each - even with the documents/data listed, the numbers don't seem to add up.

  • Diavonex Level 9 Level 9

    Check iCloud space used:



    Settings>iCloud>Storage and Backup>Manage Storage>BACKUPS

  • Julian Bashir Level 1 Level 1

    New problem following up on the previous.


    My iPad Air restoration from iPad 2 backup is not proceeding smoothly. Specifically, the Apps are taking forever to download - it's been 48 hours and I have yet to complete the download process. Granted, I had a 64gb ipad 2 but I'm using a cable internet connnection. Also, some of the Apps are being copied without preserving the folder structure from my iPad 2. There doesn't seem to be any rhyme or reason to why this is happening.


    I tried plugging my iPad Air into iTunes thinking it would reload the Apps faster, but this only results in one of the following situations each time I sync:

    1) The iPad spends a long time syncing, specifically, it hangs on Step 6 without end. If allowed to go overnight, I will discover it the next morning still on step 6.

    2) The iPad finishes syncing (per iTunes), but when I check the iPad, there are still Apps waiting to download.

    3) The iPad syncs, but then it says that 20+ apps could not be copied because of insufficient free space. A look at the status bar shows that there is at least 14-20 Gb free on the iPad Air. (***?)

    4) The iPad syncs, but the few Apps that do copy show up without the folder structure preserved from my iPad 2.


    Now, the reason I didn't want to restore from an iCloud backup is to avoid the eternal restore process. I can't figure out why it's taking so long. I kept my iPad next to my wireless router, so I know it's not a router problem. My internet was working so that's not the problem. Now.... I would be happy to restore from an iTunes backup, but I was unable to do so in the first place - kept getting "file corrupted or incompatible" message, which is what prompted me to post in the first place.


    Is anyone else experiencing this?

  • JoLy53 Level 1 Level 1

    Am experiencing exactly the same issue.  Cannot restore to a brand new iPad Air 128 from an iPad 2 32 backup on iTunes ?


    All software on both iPads and iMac uptodate.


    Any help out there ??

  • Ruud Van Driver Level 1 Level 1

    I had exactly the same issue a couple of weeks back attempting to restore my brand new iPhone 5S from my 4S.


    I had to go to Australia on business and the phone had still not finished backing up before I went and it wouldn't restart when I got to my hotel. In the end, I made a Genius appointment at the Garden City Apple Store in Fremantle where they wiped my phone and set it up as a brand new phone. I lost all of my photo stream but that wasn't a biggie as it's all on my MBP and iMac anyway.


    Next day the phone was still misbehaving in that it would not recognise UK English, even after I'd changed all the settings and installed the UK dictionary. I went to the Perth Apple Store and they swapped out my phone for a new one.


    Mahoosive respect to the Perth Apple Store (Craig Scriven and Chadd, top men!). It was iPad AIr release day and all the Genius were unavailable. I could not have picked a worse day. However, they still found someone to get me sorted.


    Anyhoo, my point is, if things are not right, I'd suggest that you go to your nearest Apple store and get them to take a look as you might just have a duff iPad.  I'm in the process of restoring my brand new iPad Air from my iPad 2 back up as I write. Already I'm having problems as it won't connect to my wifi but that might be because it's restoring. I guess I'll find out if it works soon enough..............

  • Voladero Level 1 Level 1

    I have exactlly your same problem. iPad 2 64gb to ipad Air 128gb both Wi-Fi.  Restore from backup stops abruptly after a few minutes, then continues to sync all the applications but without the folder structure.  Running mavericks with all the updates and latest version of iTunes. 


    Already tried all of Apple's support reccomendations. Feel very frustrated because I've done this process for my iPhone and friends iPads and its something that used to "just work".


    If I were to set it up as a new iPad it would work just fine, but i can't afford to lose all my documents, pdf files, and application data. 


    Searched all around the web and have found no solution.  I'm losing my patience.

  • Ruud Van Driver Level 1 Level 1

    In the end, I had to set up my iPad Air as a new device. It never did connect to my wifi so I erased everything, set it up as a new iPad and now it works fine.


    As far as I see it, you have two choices: back all your files up to your computer, set up you Air as a new device and then transfer your files across that way. Or, go to your closest Aple store and let the Genius take a looksee.


    Good luck.

  • Voladero Level 1 Level 1

    Thanks Ruud!

  • Voladero Level 1 Level 1

    Hello Ruud, I was finally able to restore my backup!  I fortunately still have my old iPad2.   This is what I did.


    In my regular account, I restored my iPad Air to factory settings. Wiped it new.

    Created a new account on my macbook and gave it administrative permissions.

    Restarted my macbook and logged in with the new account.

    Backed up my iPad2 in iTunes.  It took about 2 hours.

    After it was done, I ejected the iPad2 and connected the iPad Air.

    iTunes asked me if I wanted to restore from backup. Said yes.

    It worked. 30 minutes later my iPad Air had all my settings except for passwords.


    Hope this helps someone else!

Previous 1 2 3 Next