13 Replies Latest reply: May 17, 2014 6:01 AM by cyiza
christian Frank Level 1 Level 1 (75 points)

Since I installed mavericks, I've been having several problems. Multiple Users,etc...but what has bothered me is the problems with user permissions and the installer software. I have had problems with almost all software installers (Office, FCP, plugins, etc ...). When I try to install them I get the following message. "The Installer can not open the package. There may be a problem with file ownership or permissions" (Image). Someone is having a similar problem? How to solve this?

 

thx

 

installermessage.jpg

  • John Galt Level 8 Level 8 (40,975 points)
    • Boot OS X Recovery by holding and r (two fingers) while you start your Mac.
    • When the Mac OS X Utilities screen appears,select Utilities > Terminal.
    • In the Terminal window type resetpassword and press Enter. A window will open behind Terminal that looks like this:

     

    Unknown-1.png

     

     

    Do not enter a new password.


    • Select your startup volume at the top. From the dropdown below it, select the user account with the problem.
    • At the bottom of the window, you will see Reset Home Directory Permissions and ACLs. Click the Reset button.
    • Quit Reset Password
    • Quit Terminal
    • Quit OS X Utilities and restart your Mac.

     

  • christian Frank Level 1 Level 1 (75 points)

    Hey John. Thanks a lot!

    problem solved.

  • arthurvisser Level 1 Level 1 (0 points)

    Great. Problem mostly solved. The Application Support folder in ~/Library needed an extra fix to make Adobe CC work (Permission errors in the Adobe folder).

  • Very Siberian Level 1 Level 1 (0 points)

    Thank you for posting this very helpful tutorial! I am not able to do this on a MacBook Air with FileVault enabled. The startup volume simply does not appear in the window after I enter the resetpassword command in Terminal under OS X Recovery.

     

    Does anyone know how to reset all of the home directory permissions and ACLs under FileVault 2?

     

    TIA,

    Rob

  • DeliaSpain Level 1 Level 1 (0 points)

    Apple released Safari 7 (included with Mavericks),  Safari browser are having issues connecting to my work’s VPN. When connecting to the VPN, it will try to install the Network Connect client software then fail. I try:

     

     

    Safari->Preferences->Security tab
    “Manage Website Settings…” button in the bottom right
    Highlight “Java” from the list.
    Add your VPN site
    Click the popup menu and select “Run in Unsafe Mode”

     

    Then I can run Network Connect fine, but after 5-10 minutes it stops routing packets, I have to sign out and sign in again. Anyone else having this issue?

  • choze Level 1 Level 1 (0 points)

    Hi guys,

     

    how about this? Do you have similar experience? I tried to download Mavericks maybe 15 times (also from different connections), but the result was always this I couldn't upgrade it...

     

    I have 10.8.5, 2.66GHz Intel Core 2 Duo and 4GB DDR3 memory, MBP mid 2009.

     

    Thanks for help

    Screen Shot 2014-01-14 at 3.25.26 PM.png

  • cyiza Level 1 Level 1 (0 points)

    Hi,

    Can I try this with this problem:

    My standard user can’t now change the dock or anything he used to set-up.

    I tried to fix that by creating a new admin user and changed it for a standard one but steel the permissions are mixed up.

    And I’ve noticed that the new apps like game center have 2 users "everyone" and no one can’t be deleted.

    The disk repair doesn’t do anything(like always)…

    I’ll appreciate any advice.

    Did someone try sandbox or sparkle or another “kind of” app to reset the permissions?

    I’m looking for a book to learn how it’s work in LINUX too.

     

    Many thanks

  • jojo8026 Level 1 Level 1 (0 points)

    I tried doing this but after a couple of hours the problem came up again and I had to reset it again, then it came up again, what do i do

     

    Message was edited by: jojo8026

  • muneerm Level 1 Level 1 (0 points)

    I envy you. You were lucky not to have installed mavericks. My macbook pro has become so bloody slow that I hate every minute of using it. Is there a way to uninstall mavericks and go back to  older version of ios? Or is there a way to increase the speed?

  • petermac87 Level 5 Level 5 (6,140 points)

    Use the backup you made before you chose to install Mavericks and follow

     

    OS X Mavericks: Revert to a previous OS X version

     

    Otherwise you can troubleshoot your current system

     

    etresoft  a long time contributer to Apple Support Communities wrote a very useful app he called etrecheck which helps in diagnosing many problems caused by third party installs etc.. Go to his website, read his information and from there download and run the program according to his instructions

     

    http://www.etresoft.com/etrecheck

     

    Copy and paste the results (preferably in a new Post as this one is quite old)

     

    Pete

  • brian273 Level 1 Level 1 (5 points)

    Been trying to reset my Home Directory Permissions & ACLs via the usual route of Utilities > Terminal etc but am finding out that the Reset button has turned into a ghost and can not be clicked. This is the first time I'm trying to reset the Home Directory Permissions & ACLs since upgrading to Mavericks. Anyone help would be appreciated.

     

     


     

  • 5agarwals Level 1 Level 1 (0 points)

    I can't alter or delete files in my home folder. even the dropbox folder. I tried John Galt's solution which did not help. When trying to rename a file, I get a message that I do not have poermission to do that!!  Does this mean  my problem is not permissions related?

  • cyiza Level 1 Level 1 (0 points)

    Yes, this mavericks hein?

    The permissions are all mix-up, in my case I used onyx and after than checked all my files.... It took weeks