Previous 1 2 3 Next 62 Replies Latest reply: Jan 30, 2016 7:25 PM by NORREDIAN
ericonapple Level 1 (0 points)

After installing OSX Mavericks on my Mac Pro Book the App Store application will "open" to a blank screen but none of the functions work. If you click on  any selections (i.e., Featured, Updates, etc.) or the menu option Store, the app will clock and go into not responding mode. Since App Store is supposed to be part of the OSX install, is there some fix or a way to delete and re-install App Store without re-installing the entire Mavricks update?

MacBook Pro, Mac OS X (10.7.1), 13" with 2.66 GHz Intel Core 2 Duo
  • Carolyn Samit Level 10 (103,365 points)
    • Disable anti virus software if installed


    • Make sure the firewall is turned off in System Preferences > Security & Privacy > Firewall


    • Make sure Gatekeeper is enabled


    Open System Preferences > Security & Privacy then select the General tab.


    Make sure either Mac App Store or Mac App Store and identified developers is selected. If that area is grayed out, click the padlock icon to proceed.


    OS X: About Gatekeeper

  • ericonapple Level 1 (0 points)

    Thank you for your advice, but none of the above solutions apply to my situation:


    1. I have no anti-virus software installed

    2. The Firewall is turned off

    3. I assume Gatekeeper is enabled because Mac App Store is selected in System Preferences>Security & Privacy>General Tab

  • Carolyn Samit Level 10 (103,365 points)

    Do you have Little Snitch or Growl installed ??

  • ericonapple Level 1 (0 points)

    I have never heard of either of those apps, but neither "Little Snitch" nor "Growl" show up when I do a Spotlight search.

  • boris_ch Level 1 (10 points)

    I have exactly the same problem, and couldn't find any solution for this problem. I'll post again if I'm able to fix this annoyance somehow.

  • boris_ch Level 1 (10 points)

    AppStore also stopped working for me after upgrading to Mavericks, but I was finally able to get the thing working by partially doing what uptimistik suggested in another topic in this forum.


    Open up Terminal and type:


    sudo rm ~/Library/Preferences/

    sudo rm ~/Library/Preferences/


    (this will ask for your password).


    I also have Little Snitch installed, so I allowed all connections to the AppStore application and storeagentprocess. The developers of Little Snitch did define rules to allow these to apps to connect to *, but Apple must have changed something with Mavericks.


    After that I did a restart, and the AppStore is working again.


    Hope this helps  

  • fistobar Level 1 (0 points)

    Didn't work for me, Ihave the same endless spinning wheel issue

  • xclntgig Level 1 (0 points)

    Same issue here.  Any ideas?

  • DamsC Level 1 (0 points)

    Hi everyone !

    Same problem here for me, since I updated to Mavericks...

    (MacBook Pro Early 2011, i7 2,2Ghz, OSX 10.9)


    Mac App Store doesn't launch at all. When I click, only a white little flash on the screen, and then nothing...

    - Tried the Carolyn Samit solution : Eveything is well configurated.

    - Little Snitch or Growl : I have Growl, but never used it (I don't know really why I put it...). I tried to delete it, but it seems to be impossible, because it is not considered as an application( or I don't know how to do).

    - boris-ch solution : I can't test it. My Terminal doesn't launch at all... Same little white flash on the screen and nothing happens...


    Furthermore, Mail has a malfunction : it opens and shows me the mails, but when I click on a mail, there is no preview in the right side, only a grey background. And when I open a mail by double-click, it opens a grey window, and 2 secondes later, the app crashes.


    Anyone has an idea ?

    Thanks for your help.

  • boris_ch Level 1 (10 points)

    After running the fix I described in a previous message, my AppStore stopped working again.


    Browsing through this forum didn't help at all, but I finally found this post by Joseph Scott:



    Finally a solution that actually solved the problem!!


    1. Shut down your Mac.
    2. Locate the following keys on the keyboard: Command (⌘), Option, P, and R. You will need to hold these keys down simultaneously in step 4.
    3. Turn on the computer.
    4. Press and hold the Command-Option-P-R keys before the gray screen appears.
    5. Hold the keys down until the computer restarts and you hear the startup sound for the second time.
    6. Release the keys.


    Thank you, Joseph


    Note: when started again, AppStore shows app updates are available, even though I updated the apps minutes ago. I'll try to find a solution for this problem, but at least now I can browse the AppStore and install apps.

  • wkhatch Level 1 (0 points)

    Carolyn Samit's fix worked for me. I'd had to set my security for apps to "Anywhere" a few weeks back in order to install something not from the store. As soon as I switched it back, the app store app was responsive and working. Doesn't seem like it should work like that, however. My preferences regarding what and where I allow apps to come from should NOT affect the function of the App Store app.


    Update: I spoke too soon. Although the app became responsive after those changes, it still won't "do" anything. I can't install updates, switch tabs, install new software, etc.


    Message was edited by: wkhatch

  • rjrudi Level 1 (0 points)

    I have a solution for my case which might apply to you also. Firewall was enabled, but the App Store was not listed in the firewall exceptions list. To allow App Store to function I had to add it to the list. This is how: Apple Menu Icon => System Preferences => Security & Privacy => Firewall (see Note below) => Firewall Options => Plus + Sign Button => Browse to or Select pulldown menu for Applications => Select App => Add button => OK. Note: if the padlock icon is locked in the Firewall screen, click it and provide the administrator password to unlock, then continue with the trail of =>. Restart the app store application. Maybe this will help you; please us know. Thanks! Bob.

  • Cac450 Level 1 (0 points)

    Did you find how to solve the problem?. I have the exact same issue.

  • Tamer2014 Level 1 (0 points)

    same happened with me

    any suggestion ?

Previous 1 2 3 Next