Previous 1 2 3 Next 30 Replies Latest reply: Dec 8, 2014 8:46 AM by PTC Bill
MarkR1653 Level 1 Level 1 (0 points)

It was stupid of me to accept my Apple TV's notice of a new upgrade, which I accepted, and it is now version 6.0.1.  I upgraded my iTunes to 11.1.3.8.  Now my Apple TV doesn't recognize my Home Sharing with my computer.  I've reset the Apple TV to download the latest software again, and still nothing.  Before the update everything was fine.  This is not some Windows 8/firewall/network issue.  This is an Apple TV/iTunes/Home Share issue.  I have restarted Home Sharing multiple times in iTunes with my account without any success.  Please help.  Thanks.

 

Mark


AppleTV 2, Windows 8
  • diesel vdub Level 7 Level 7 (21,975 points)

    Works the same in the current version as every other previous version.

     

    The issue is network related as the ATV simply does not see a computer on the network with iTunes running and Home Sharing enabled.

  • tlovejr Level 1 Level 1 (0 points)

    I have the same problem. Tonight is the first time I've tried to connect my apple tv since mavericks and it wont connect.  I had an apple tv update waiting, so I installed it hoping it would make a difference.  It didnt.  Having a dinner party but cant connect my home sharing.

  • guitarsonmars Level 1 Level 1 (0 points)

    I just upgraded too and now the homesharing icon is gone from itunes... I have two apple express and two apple tv's and none of them can connect to the computer until I can figure out how to get the icon back I have tried updating all software on the routers and tvs and turning everything on and off again to reboot. Homesharing is turned on on everything too. I can send music from my iphone and ipad through Airplay just fine so I know the wireless is working.

     

    Anyone have any ideas how to get the homesharing icon back on itunes after the latest update??

  • diesel vdub Level 7 Level 7 (21,975 points)

    Considering the issue started after installing Mavericks, have you considered that something in Mavericks is the culprit?  I seem to remember reading in another post that after installing Maverick that the firewall gets re-enabled.  Check that.

     

    The ATV is not the issue, something on the network is causing the problem.

  • guitarsonmars Level 1 Level 1 (0 points)

    Hi guys! I have just found a solution in a different thread - huge thanks to Toploader21120:

     

    1) open control panel.

     

    2)Choose Network and internet

     

    3)Select the VIEW NETWORK STATUS TASKS under NETWORK and SHARING CENTER section

     

    4) Choose the active network connection. It is usually name " wireless Network Connection 1" or something similiar.

     

    5) Click the properties button

     

    6) If the Internet PROTOCOL VERSION 6(TCP/IPv6) is checked, uncheck it, then click OK.

     

    7) Click CLOSE

     

    8) Restart iTunes and try to use the Home Sharing feature again.

     

     

  • MarkR1653 Level 1 Level 1 (0 points)

    I was able to talk directly to Apple tech support - someone who knew what he was talking about.

     

    Through the command prompt, we were able to successfully ping my computer through the router, but the Apple TV was not able to be pinged.  We looked at all of the router settings (tech support was remotely connected to my computer) and everything looked fine.

     

    Again - the Apple TV worked FINE prior to the latest software update.  I had no problems with Home Share between my Windows 8 machine, router, Apple TV.  The latest software update is the ONLY change I've made.

     

    The helpful Apple tech guy didn't understand why it would be doing this, so is sending a replacement Apple TV.  We will see if this helps.  If not, I will try the above possible solution - but it's difficult for me to believe it's a Windows 8 network connection issue.  I feel it's an issue how the Apple TV is communicating to the router (although connected wirelessly).

     

    Thanks for the input.

  • tlovejr Level 1 Level 1 (0 points)

    Something in the other referenced thread worked for me.  The Mavericks install turned on my firewall.  In the firewall, iTunes was set to "Deny incoming connections". I changed it to allow, and the home sharing from ATV is working again.

     

    Wow, that seems like a huge overstep on the Mavericks installation - "gee, lets turn on this users firewall and then deny one of our primary product services - iTunes.  That should serve the customer well..."

  • bluenosr Level 1 Level 1 (0 points)

    Oh....my....GOD. I too updated Apple TV yesterday and from then on HomeSharing would not connect to iTunes on my PC. After f*cking with this stupid thing for 4 hours today ( the apple tv, my network, my PC), nothing worked. I read this thread and unckecked the ipv6 check box. Voila, I'm back in business! To be honest, I have no idea if this box was checked before the update or not, but clearly Apple TV does not like it checked.

  • pgausman Level 1 Level 1 (0 points)

    Worked for me too!  I was at the end of my rope.  Unchecked ipv6 on both wireless and LAN and my iTunes library showed up just like that in both Remote and in Music apps.  Thanks guitarsonmars.

  • colinfromdunstable Level 1 Level 1 (0 points)

    They are a nightmare, every iTunes update kills the HomeSharing to my ATV2.

    I only use the ATV to view stills on my WinXP system, but I do backup my iPad on the PC.

    Happily, an ATV s/w update fixed it, but why don't they publish release notes confessing to these potential problems ??

  • FastEddie77 Level 1 Level 1 (0 points)

    This worked for me immediately as well.  Just unchecked IPV6(TCP/IPv6) and it worked right away.  Even though my Netflix was still working (wi-fi and hard line). This solved the problem. 

    Good call and exellent advise!! 

    Thanks for posting Guitarsonmars!!

  • laytoncy Level 1 Level 1 (0 points)

    The IPv6 solution worked for me as well.  I'm running Windows 7, latest iTunes and an ATV2 with an old version of iOS.  This is not limited by any means to updated versions of iOS on ATV2.  The latest version of iTunes broke this for sure.  Thank you very much for the fix.

  • Hypot Level 1 Level 1 (0 points)

    The IPv6 uncheck thingy worked for me too.  Was quite frustrated until I stumbled upon this thread.  Seems like such an oddball setting to have to make.

     

    Thanks for posting the fix!

  • LRHSTL Level 1 Level 1 (0 points)

    Confirmed.

     

    Been fussing for three days trying to get my ATV2 to see my home sharing Windows 7 PC to play nice.

     

    Fussed with firewall, router, AV. Everything. No joy.

     

    Read this post, went into Windows 7 control panel, disabled IPV6... And as Emeril would say : "Bam! There it is!"

     

    Life is good.

Previous 1 2 3 Next