10 Replies Latest reply: Apr 23, 2014 10:37 AM by mike.habermeier02
wlfairman Level 1 Level 1 (0 points)

Running OS-X 10.8.5 on iMac 27 Late 2013. Everything goes smoothly installing Windows 7 64-bit with Boot Camp 5.0.4 until Windows does its final reboot (after a complete, apparently successful install), and begins the Windows setup sequence. The first setup screen asks for User name and PC name. My mouse and keyboard do not work at this point. Tried cold rebooting: Windows boots up, detects it needs to do first use setup, and gets to same failure point.

 

NOTE: I have never had a chance to install the Windows support drivers; but the mouse and keyboard worked through out the istallation.

 

I've tried two different W7 versions: 64-bit Pro and 64-bit Enterprise [Enterprise is not supported, but I have installed it on an iMac 27 2010, and a MacBook Air 2013.]. Both versions of W7 hang at the same point described above.

 

I've tried a Windows DVD install disk  plus Windows support drivers on a flash drive; and I've tried a bootable flash drive with everything on it. Both fail at the same point.

 

I have tried both wireless and USB keyboards and mouse. Same failure.

 

I have even tried removing the flash drive with Windows support drivers before the final reboot. Same failure.

 

NOTE: when I reboot in OS-X and go to the Startup Disk, the windows option says "Untitled Windows" instead of Boot Camp; but I can select it, and it starts the Windows boot which ends up at the same Windows setup failure point.

 

Has anyone had the same problem?

 

Has anyone succeeded? If so, any special actions or ideas?


OS X Mountain Lion (10.8.5), iMac 27 Late 2013
  • Abdessattar Level 1 Level 1 (0 points)

    The issue may be related to the iMac 2013 only having USB 3.0 ports and that windows 7 does not come with drivers for it. Try the following (borrowed from answer on Mac Rumors Forums http://forums.macrumors.com/showthread.php?t=1659481):

     

    <quote>

    If you run into issues with keyboard and mouse not working (due to USB 3.0 and Win 7 incompatibility), you need to run your Win 7 partition (and Win 7 installation disk/partition) in legacy mode. (I found this information at:http://twocanoes.com/winclone/support#faq123 - see "Method using Terminal"). Here you will be setting the legacy on the installation volume of win 7, not bootcamp partition (yet). After running the diskutil list find the volume with installer of Win 7, and then run the command (substituting the disk1s2 below with the information you find through diskutil on your computer:


    sudo /usr/sbin/bless --device /dev/disk1s2 --setBoot --nextonly --legacy


    Enter administrative password when prompted. Next, select Restart from the Apple menu. Do not hold the Option key while restarting.


    You should have mouse/keyboard working. Begin the Windows 7 installation. Upon first restart right after the installer completes, boot into Mac and set the legacy mode for the BootCamp partition (but this time without the --nextonly flag), so you can use keyboard/mouse to complete the installation and thereafter until the USB 3.0 drivers are installed).

    </quote>

  • Abdessattar Level 1 Level 1 (0 points)

    By the way, if you are installing from a USB drive, you may also get an error during the setup (right after the language selection) that setup cannot find drivers for whatever hardware device it will come up with... That is because the USB flash drive containing windows setup files is not working at that time.

     

    Just remove the USB drive and plug it in another port and Windows setup will redetect it. This worked well with Windows 8.x install on the iMac 2013. I hope it will work for you on Windows 7.

  • wlfairman Level 1 Level 1 (0 points)

    I tried another "experiment:" booted into windows and since I had to previously do a cold power down to leave windows I get a black and white screen with options for a Safe, Safe with Networking, Safe with Command Prompt and Normal Start Up. I had been allowing the default normal start to occur just by waiting for the timeout to expire. But this time II selected the Safe Mode USING MY KEYBOARD. It started to load windows with drivers, detected that setup had not yet occurred, and gave me a dialog box telling me to restart the computer. By then, the keyboard and mouse didn't work; and a cold power down was required.

     

    In short the keyboard is working (at least the arrow keys and the return key) when Windows detects an interrupted session during cold startup, but then some subsequent activity (ladding a conflicting driver?) causes the keyboard to stop working after the boot up completes.

  • wlfairman Level 1 Level 1 (0 points)

    I will try your suggestions tomorrow morning. Many thanks for the help. I'll post my results.

  • wlfairman Level 1 Level 1 (0 points)

    I am having trouble with the sequence of the "legacy" intervention. Could you please provide a list of the order of events assuming I am starting (1) without a windows partition (i.e., Boot Camp has not run yet); and (2) I have a USB drive containing both the W7 64 bootable installation and the latest Windows support drivers.

     

    I can use diskutil to find the disk designation of the installation USB and the Windows partition because I have done that after failed install. If I use the following to change the attributes of the USB install flash drive

     

    "sudo /usr/sbin/bless --device /dev/disk1s2 --setBoot --nextonly --legacy

    Enter administrative password when prompted. Next, select Restart from the Apple menu. Do not hold the Option key while restarting."

     

    before I run boot camp, then when I do the Apple menu restart it will begin to boot from the USB but I don't have the actual Windows partition yet on my Hard Drive. But if I run boot camp before the above sudo command, I go right into installation.

     

    I am trying the above "sudo ..." after I have terminated a windows install after boot camp partitioned the hard drive. Even if that is correct, I am still not sure where the second sudo intervention occurs since I would not get back to OS-X in the ordinary install of W7).

     

    Again, thanks for any additional help you can provide.

  • Abdessattar Level 1 Level 1 (0 points)

    The best thing is that you run bootcamp assistant before, when you are done, it will automatically boot in legacy mode for you and you will see the mouse and keyboard.

  • wlfairman Level 1 Level 1 (0 points)

    I was able to do both "sudo" commands. The first as I described by getting the partition in place, then setting the nextonly and setBoot and legacy attributes to the installation USB and restarting from the Apple menu. The second by using the option key [To select Mac] when the windows install did its first reboot after the complete installation. But no luck.

     

    I really appreciate all your help, but I have not been able to see the key board or mouse once windows gets into the setup sequence after the install completes. The mouse and keyboard work fine for everything before this setup sequence. And they did even without the legacy attribute.

     

    Thanks,

    Bill

  • wlfairman Level 1 Level 1 (0 points)

    Well, magic is sometimes best. On my second call to Apple Care, the senior advisor suggested I try the following:

     

         0) start with a blank USB flash drive

         1) plug the USB Flash drive into the left-most USB port as you face the front of the iMac (the one closer to the mid plane of the iMac)

         2) attach the superdrive to the right-most USB port and load an install DVD

         3) launch boot camp selecting the second and third boxes (create support driver USB flash drive and install Windows 7; i.e., do not create a self contained bootable USB flash installation drive)

     

         It worked! That was easy.

  • BlackenedDefias Level 1 Level 1 (0 points)

    Just solved this.

     

    If you are downloading the support software/windows iso (through bootcamp) onto an external USB device make sure it's USB 2.0 device. Otherwise the keyboard and mouse will not work.

     

    I have a 27in Haswell iMac and put the 2.0 device into the slot closest to the center of the machine (closeset to the iMac stand.

     

    Hope this helps!

  • mike.habermeier02 Level 1 Level 1 (0 points)

    THANK YOU.

     

    Thanks for sharing. It works like a charm. !
    Great I found this solution after 2 hours of trying.

     

    !! Great!