Previous 1 2 Next 17 Replies Latest reply: Jul 14, 2014 9:15 PM by Gofastchickenwing Branched to a new discussion.
Living Fossil Level 1 Level 1 (90 points)

When someone sends an SMS to my phone number (this may be someone without an iPhone, so I suppose not part of the iMessage system), I sometimes see it in the 'messages' on my iPhone but sometimes it doesn't appear there: on the other hand, all messages sent to my phone number appear on my iPad (on the same wifi network as my iPhone, if that matters). If I look at the messages on my iPhone right now, I see messages sent a few days ago, but not one sent yesterday, which is clearly visible in 'messages' on my iPad! I don't think I have changed any parameters lately.

 

It is obviously vital that all messages (iMessage or straightforward SMS) sent to my phone number should go to the iPhone with that number, specially if I don't have access to my other iOS devices - how can I ensure this?

 

I have looked at other discussions here but I can't find a straightforward explanation of this. Can anyone help?


iPhone 5, iOS 7.0.3, 16Gb
  • braden85 Community Specialists Community Specialists (3,695 points)

    Hey Living Fossil!

     

    I have an article that suggests some settings for you to check out that address this issue:

     

    iOS: Using Messages

    http://support.apple.com/kb/HT3529

     

    Additional Information

    • You can change the address that new iMessage conversations are started with in Settings > Messages > Send & Receive > Start new conversations from:. Note that this setting applies only to new conversations. If you would like to change the address from which messages are sent, first change this setting, and then delete the existing conversation and start a new one.
    • iMessage responses will be sent from the address the recipient most recently messaged. For example, a friend sends you a message to your Apple ID. Responses in this conversation will be sent from your Apple ID, even if you've selected new conversations to start from your phone number.
      HT3529--addresses-001-en.png

     

    Thanks for being a part of the Apple Support Communities!

     

    Cheers,

    Braden

  • Living Fossil Level 1 Level 1 (90 points)

    Thanks for your response. Sadly so far, I don't think this has helped me: the documents seem to be about messages sent from me to other people. I primarliy interested in incoming messages. I still don't understand why I have a different (and shorter) message log on my iPhone when compared to the message log on my iPad. I am using the same Apple ID throughout, and I only have one phone number. I want all messages addressed to me, whether iMessage, SMS or MMS to show up on my iPhone. I am happy if they show up on my iPad too, but this is not the priority. Basically if I am carrying my phone around and have left the iPad at home, I need to be sure that all messages sent to me appear on that phone. Otherwise obviously I risk missing stuff that may be important. I will read the article again, but on first reading it doesn't seem to answer the question "Why don't all messages sent to me end up on my iPhone?". I realise this is not quite the question I asked initially, but on looking at the actual message log, I see that my phone missed some (but strangely not all) of the messages sent to me from another particular iPhone. I don't think the owner of this phone has changed any of the parameters at her end: I think she just thinks she's sending them to my phone number. Since my iPad isn't a phone (and isn't even a G3 model) it's incomprehensible to me that the phone doesn't get the messages and the iPad does.

  • yni Level 1 Level 1 (0 points)

    I am having the same problem: getting some messages on my iPad and not on my iPhone.  Your situation may be different, but I checked out my settings and noticed that iMessage was turned off for my iPhone (I had done this to solve a different problem).  I am turning on iMessage on my iPhone with the hope that this will fix my issues (and hopefully not resurrect the other problem) because I noticed that at least some of the messages being received only by my iPad were from Apple device users.  Good luck!

  • braden85 Community Specialists Community Specialists (3,695 points)

    Hi again, Living Fossil!

     

    Thank you for using the Apple Support Community. Due to the nature of your issue or question you may find more information by using another one of Apple's support resources - https://getsupport.apple.com/GetproductgroupList.action.

     

     

    Cheers,

    Braden

  • Living Fossil Level 1 Level 1 (90 points)

    Thanks for the suggestion. Right now for some reason I can't get this link to work (I get a 'not available just now' type of message from Apple). I'll try again.

     

    Meanwhile, I think maybe there is another factor in play, which is that my correspondents and I move around European countries (lately France, UK, Spain, Italy), so some messages originate from one country and are sent to another one. This shouldn't matter - any SMS sent from Skype for example always gets there regardless of the sending and receiving countries, and if I'm outside the phone contractor's 'home' country (UK), I have a contract which allows me to call and receive in all the countries involved, but it just MIGHT be a factor. I am still completely foxed.

     

    I'll try the link again fairly soon and get back to the list.

  • FrustratedinSeattle Level 1 Level 1 (0 points)

    I was having a remarkably similar problem.  My SMS messages (and iMessages) that I sent to a friend's phone number were being received only on her ipad (which does not have G3).  Somehow, we were able to tweak some setting (don't know how or what) and now the problem is solved.  She gets my messages on her phone.  Less of a problem is that now she does not get them on her ipad.  Did you ever figure out what was going on?

     

    Lee

  • QuocTran Level 1 Level 1 (10 points)

    This happens if you are not on wifi on your phone but your ipad is on wifi. iMessage only recieves it on the device that is currently on wifi. Therefore, if you don't want to get messages on your ipad and not your phone, then either always have them together on wifi, or turn off your wifi on your ipad when it is not with you

     

    For example, I leave my ipad at home but go out with my iphone. While i'm roaming, I don't have Wifi, so i don't get iMessages but people can still send me messages since my iMessage account is still logged on via iPad at home. If both devices are off wifi, then the sender of the message will get a send error instead since the message cannot be delivered

     

    I hope I cleared this up for you guys.

  • Living Fossil Level 1 Level 1 (90 points)

    Well, that's the clearest explanation I've ever seen! Thanks a lot. Sad that it works that way, since my iPad is shared by other members of my family and tends to be at home with the wifi on all the time, while I wander arount with my iPhone which goes in and out of both wifi and phone networks according to location. If I could tell it to stay on wifi but not pick up messages, I would, but I don't think that's possible, is it?

     

    Thanks very much

  • nackerm Level 1 Level 1 (0 points)

    can you not switch iMessage off on your iPad (Settings/Messages)?

  • david.sorensen Level 1 Level 1 (0 points)

    I dont mean to be so blunt, but "QuocTran" from above is wrong. That is not the case. You can in fact receive iMessages to your iPhone even when you are not connected to wi-fi. You should shut off iMessage on all of your devices including your phone and then turn only your phones iMessage on. Apple was having some problems with iMessage a few months ago with similar issues and im not sure if they are still working on them, but my method should work for you. The reason for this is when you turn off iMessage form all of your devices, it will unregister your number in the iMessage system. Once it is unregistered, you can re-register it on your phone by simply turning your phones iMessage back on.

  • david.sorensen Level 1 Level 1 (0 points)

    I dont mean to be so blunt, but "QuocTran" from above is wrong. That is not the case. You can in fact receive iMessages to your iPhone even when you are not connected to wi-fi. You should shut off iMessage on all of your devices including your phone and then turn only your phones iMessage on. Apple was having some problems with iMessage a few months ago with similar issues and im not sure if they are still working on them, but my method should work for you. The reason for this is when you turn off iMessage form all of your devices, it will unregister your number in the iMessage system. Once it is unregistered, you can re-register it on your phone by simply turning your phones iMessage back on.

  • david.sorensen Level 1 Level 1 (0 points)

    I dont mean to be so blunt, but "QuocTran" from above is wrong. That is not the case. You can in fact receive iMessages to your iPhone even when you are not connected to wi-fi. You should shut off iMessage on all of your devices including your phone and then turn only your phones iMessage on. Apple was having some problems with iMessage a few months ago with similar issues and im not sure if they are still working on them, but my method should work for you. The reason for this is when you turn off iMessage form all of your devices, it will unregister your number in the iMessage system. Once it is unregistered, you can re-register it on your phone by simply turning your phones iMessage back on. If this doesnt work, you can always try resetting the netowork setting on your devices. Settings > General > Reset > Reset Network Settings.

  • david.sorensen Level 1 Level 1 (0 points)

    I dont mean to be so blunt, but "QuocTran" from above is wrong. That is not the case. You can in fact receive iMessages to your iPhone even when you are not connected to wi-fi. You should shut off iMessage on all of your devices including your phone and then turn only your phones iMessage on. Apple was having some problems with iMessage a few months ago with similar issues and im not sure if they are still working on them, but my method should work for you. The reason for this is when you turn off iMessage form all of your devices, it will unregister your number in the iMessage system. Once it is unregistered, you can re-register it on your phone by simply turning your phones iMessage back on. If this doesnt work, you can always try resetting the netowork setting on your devices. Settings > General > Reset > Reset Network Settings.

  • david.sorensen Level 1 Level 1 (0 points)

    I dont mean to be so blunt, but "QuocTran" from above is incorrect. You can in fact receive iMessages on your iPhone even when you are not connected to wi-fi. You should shut off iMessage on all of your devices including your phone and then turn only your phones iMessage on. Apple was having some problems with iMessage a few months ago with similar issues and im not sure if they are still working on them, but my method should work for you. The reason for this is when you turn off iMessage form all of your devices, it will unregister your number in the iMessage system. Once it is unregistered, you can re-register it on your phone by simply turning your phones iMessage back on. If this doesnt work, you can always try resetting the netowork setting on your devices. Settings > General > Reset > Reset Network Settings.

Previous 1 2 Next