6 Replies Latest reply: Nov 11, 2013 10:15 PM by BDAqua
Joseph Byrnes Level 1 Level 1

Running Onyx, it tells be my disk needs repair

 

disk utility/disk repair (run from separate boot drive) gives me this result:

 

invalid volume file count

it should be 689947 instead of 689948

 

Disk Utility successfully repaired the disk.

 

I've read other posts similar to this, none of which answers my questions:

 

1. What is causing this?  It's the second time this month this has occurred, never before in six years.

 

2. What steps do I take to prevent recurrence?

 

Thanks.

 

joe

Reply by BDAqua on Nov 11, 2013 6:26 PM Helpful

Hi Joe, Some causes are...

 

Untowardly shutdowns of the Mac.

 

Some App or Process dying in mid stream.

 

Flaky RAM.

All replies

  • BDAqua Level 10 Level 10

    Hi Joe, Some causes are...

     

    Untowardly shutdowns of the Mac.

     

    Some App or Process dying in mid stream.

     

    Flaky RAM.

  • Joseph Byrnes Level 1 Level 1

    Hey BD,

     

    Any way tp figure out which it is?

     

    I tested the RAM (TechTool Pro) multiple times (in case the problem was intermittent) and it seems fine.

     

    I haven't had any weird freezes or shutdowns. Occasional restarts, but nothing unusual.

     

    Don't know if that narrows it down to some App or process, but how do I determine what's what?

  • BDAqua Level 10 Level 10

    RAM can be really tough to test, takes days, then you can only trust it if it finds a problem, not if it doesn't.

     

    How old is this drive?

     

    You may or may not find some clues in Console>All logs, maybe search for...

     

    abnorm

     

    exited

  • Joseph Byrnes Level 1 Level 1

    Console shows no exited or abnormal exits after 2012

     

    I can't help but think this has something to do with my recent problems with the router that we worked on, though what it could be, I don't know. No new software running in support of it.

     

    Or could it possibly be sugarsync, which warns me that 105.8 is no longer supported and I might get errors, etc.  Although nothing happened until recently and I've used sugarsync for a year.

  • BDAqua Level 10 Level 10

    Sugarsync has never worked right for me here, I think it very well may be the problem.

  • BDAqua Level 10 Level 10

    To clarify, it works OK in 10.8.5 & up, but was problematic in 10.5.8 & lower, never tried it in 10.6.x