2 Replies Latest reply: Nov 12, 2013 12:05 PM by cherrybombc2
cherrybombc2 Level 1 (0 points)

I updated Keynote Pages and Numbers because I was told to by my automatic updates.


MacBook Pro late 2011 model running OSX Maverick 10.9


Both versions are on here. Old versions run but the 2013 versions of all 3 crash before they even open. Why?

MacBook Pro, OS X Mavericks (10.9), updated Apple notified updates
  • adp1983 Level 1 (70 points)

    I had a simular problem last week.


    I deleted them completely from my macbook pro (old and new versions) and then redownloaded them from the Purchases section from the app store app.


    This sorted the problem out for me.


    Hope this helps

  • cherrybombc2 Level 1 (0 points)

    Well to anyone listening.  Thanks adp1983.  I'm not really interested in buying a new copy. I haven't even owned this suite for 2 years.


    So I poked around some, went back and made sure I updated to 9.3 for all three.  Then I tried reinstalling, made the changes to the language like some have suggested. I logged into the guest account to try to run it and THAT WORKED.


    But when I came back to my account, the only way I can make any of the apps run is by:


    Open Applications in Finder.

    Find App.

    Right click on the app. Open Package Contents. Go to the Mac OS folder, find the app (black squre)

    Right click on the app. Open wth Terminal. It runs it and opens it just fine.


    I can create and save documents in any of the three new apps. I can save the docs and open the apps through the documents.






    Some one please help me.  Thanks for your answer too