7 Replies Latest reply: Jun 22, 2015 5:03 AM by cnu swiss
High Energy Level 1 Level 1 (0 points)

After I downloaded iOS 7.0.3 Data plan is not working in my iPhone5; I tried resetting network; powered down and powered on; switched off LTE, airplane mode on and off; Cellular Services on and off, nothing seems to work.  Should I try Total Reset? (of course after backing up in iTunes)?


iPhone 5, iOS 7.0.3, 3G Data Plan not working
  • mario49 Community Specialists Community Specialists (3,590 points)

    Hello High Energy,

     

    Thanks for using Apple Support Communities.

    For more information on this, take a look at:

     

    iPhone: Troubleshooting a cellular data connection

    http://support.apple.com/kb/TS3780

     

    1. Ensure that your software is up to date:
    2. Remove the SIM Card and reinsert it. Allow the iPhone to acquire the network again.
    3. If your SIM card has SIM PIN enabled, try toggling it off: Tap Settings > Phone > SIM PIN.
    4. Try another location. If a different location works, but the original location still does not, contact your carrierto report the issue.
    5. Reset network settings: Tap Settings > General > Reset > Reset Network Settings.
    6. Restore the iPhone as new.

     

     

    Best of luck,

    Mario

  • EdBelgium Level 1 Level 1 (0 points)

    Hi,

     

    did all of the above, still not working. 3g turns off my Carrier (No Service). I tried this on an Iphone 5 16gb, sim working fine. Put it back in my Iphone 5 32gb and it doesn't work anymore. Phone faulty ? Weird as before IOS 7.0.3 it was working fine. Now with IOS 7.0.4 still same problem. So did IOS 7.0.3 update KILL the Iphone's hardware ? Doubtfull, but with Apple you never know ?

     

    Seems I am not the only one with this problem. Found people on T-Mobile, Vodaphone, etc with same issue. I am on TELENET (belgium) which uses the Mobistar network. I have a feeling something is wrong in IOS 7.0.3 as before my 3G plan was working perfectly.

     

    Did

    Reset network -> no luck

    Erase all settings and data (full reset) -> Set up as NEW phone -> no luck

    Restored backup -> no luck

     

    I found a link saying the network PLIST is crap, but for that you need root (jailbreak) access. Or an update from APPLE to fix the PLIST.

     

    I been without 3G for about 3days

    Follow this steps

    1.Turn off 3G,cellular data,& location services

    2.Reset network settings

    3.Restart phone

    4.Go to cellular data network & insert your carrier's APN (if u don't know visit carrier's site)

    5.Now turn on 3G,cellular data, and location services wait for 10 seconds

    6.After 10 seconds restart phone

    7.After this let the phone search for signal(you can turn on airplane mode & wait till carrier disappears & turn off mode again)

    8.you might have to do that 3 or 4 times finally you will get 3G back on

    If this method don't work then you must edit the network plist and delete entries of carrier info

     

     

    Any suggestions ?

     

    Regards

    Edwin

  • EdBelgium Level 1 Level 1 (0 points)

    I did the following test :

     

    My Iphone 5 32gb with TELENET (belgium)

     

    Put a PROXIMUS (belgium) nano simcard in my Iphone 5 32gb -> Result -> 3g working FINE !

    Put my TELENET nano simcard in my wife's Iphone 5 16gb -> Result -> 3g working FINE

     

    Put my TELENET nano simcard BACK in my own Iphone -> Result -> 3g "no carrier/no service"

     

    I was on PROXIMUS before, so even after full reset the phone, setup as NEW PHONE in itunes even, nothing gets better. Once I put the TELENET simcard in my own Iphone, (32gb), no 3G possible and no more service. On 2g it's fine.

     

    This is a fully sim-free 800 euro Iphone worth nothing right now. This all started after IOS 7.0.3 ...

     

    Both Iphones are running IOS 7.0.4

     

    Hope this helps to debug/fix

     

    Regards

  • EdBelgium Level 1 Level 1 (0 points)

    Contacted Apple Support Netherlands, very professional, very polite and explained my problems. They decided to send me a replacement Iphone and IT WORKS !!! I have no clue why on proximus my former iphone worked fine, and not on Telenet, but with the replacement Iphone I got within 24h!! (great service!) it was working straight away. The Iphone had IOS 6.1.4 in it, and I was reluctant to update, since I didn't want too loose 3G again.

     

    So first setup as new Iphone, all working... then updated to IOS 7.0.4, that went fine...and YES ! STILL 3G !!

     

    So then restored my former phone's backup, crossed fingers and STILL ALL GOOD !! So def something went wrong when I went from IOS 7.0.2 to 7.0.3, this is where I lost 3G on the Iphone.

     

    Now it went from 6.1.4 to 7.0.4 and 3G is working as it should

     

    Very Happy Apple Customer !

     

    Regards

    Ed

  • ruthlin Level 1 Level 1 (0 points)

    I recently upgrade my Iphone 5 to IOS 8.0.2 and my 3G lite was not working. So i followed:

     

    5. Reset network settings: Tap Settings > General > Reset > Reset Network Settings.

     

    Problem solved.

     

    Thank you Mario49

  • GustavoGus Level 1 Level 1 (0 points)

    I got the same problem.

     

    I bought my Iphone at may 2013 and last 2 days the 3g is saying searching all day long.

     

    I've tryed all the steps EdBelgium wrote above nad still not working.

     

    NOw i'm living in Brazil and Apple here they made all steps again and charge me U$380 to fix my Iphone in 7 business days.

     

    The same price of a new one.

     

    Its unbelievable cause its seems to be a internal problem and not a malfunctioning cause by the user.

  • cnu swiss Level 1 Level 1 (0 points)

    Oh my God!!!!!!!!!

     

    Thank you so much. It worked. The problem is because of location services.

    just turn off the location services, cellular data and restart the phone and it works.

     

    DO NOT TURN THE LOCATION SERVICES ON.