1 Reply Latest reply: Nov 13, 2013 3:20 AM by Winston Churchill
marekfrombc Level 1 (0 points)

When I restarted the Apple TV, I couldn't find the movie anywhere. Went back and tried to rent it againg, only to get a message that I've already rented it and to go to Settings and check for Downloads. There is no Downloads menu in Settings anywhere. I tried to rent the movie couple of more times with the same results. I even got the same answer when I tried to Buy the movie. Only thing i could find in Settings was 'Check for rented items' but when I clicked on it nothing happened. Frustrating.....

  • Winston Churchill Level 10 (93,195 points)

    Welcome to the Apple community.


    A number of people have reported similar issues recently, many appear to have found a discrepancy of some kind in their account settings and making changes to these settings or simply resetting them has resolved the matter.


    Check your account details are correct, check that you are using the correct details for Location, Region and Time Zone. You may want to change these settings and then change them back to see if that helps.


    You might also try logging out of and then back into your iTunes account (Settings > iTunes Store > Apple ID’s > Sign Out) and restarting your router. (Some have reported that after doing this, they need to check for rentals even though it may report that there aren’t any, after which rentals once again appear in the ‘movies’ feature)


    Rentals should appear under their own heading in the ‘Movies’ feature, you might also check at Settings > iTunes Store > Check For Rentals.