Previous 1 2 3 4 5 Next 379 Replies Latest reply: Mar 24, 2015 9:11 AM by francescofromrm Go to original post Branched to a new discussion.
  • Gooner1999 Level 1 (0 points)

    i also have the same problem, iphone/ipad working well but mail not updating with Gmail server. However, mail also has 4 other gmail accounts and all these work fine, so at a loss as why 1 out of 5 shouldn't sync properly. have deleted the account, restarted mail many times and this updates mail for all accounts...but sadly is only temporay fix for the 1 as it never lasts longer than initial sync.

  • jenslapinski Level 1 (0 points)

    I had the Mac Firewall on. Mac Mail didn't sync. Then I turned it off. Sync worked as it should do.

     

    Seems to me that in Mavericks the System firewall interacts incorrectly with Mail. This will need fixing.

  • marcas91 Level 1 (0 points)

    SAME ISSUE! However, everything (message location, unread status) syncs on ALL of my other accounts (IMAP and Exchange), just not my 2 Gmail accounts. I can QUIT Mail, and then Gmail syncs normally (the first time). However, I have to go to Mailbox > Synchronize to get Flagged status to sync for one of the accounts, although that may be an issue with the mail server.

     

    WOULD LOVE A FIX, APPLE! Or at least a workaround...

     

     

    UPDATE: I did as someone above suggested and turned off Mac Firewall. Quit Mail and restarted, sent messages from my iPhone (Gmail) to myself (Gmail), and everything works as expected when I click the envelope to get new mail (at least for now it does)...

     

    Anyone experiencing the same fix?

     

     

    UPDATE 2: I turned Firewall back on, and added Mail to its list (Allow incoming connections). Still working... for now.....

  • Donald Morgan Level 6 (12,770 points)
  • marcas91 Level 1 (0 points)

    The Mail for Mavericks update didn't change anything about my situation...

  • Donald Morgan Level 6 (12,770 points)

    http://support.apple.com/kb/TS3276

    Here is yet another fix.

  • marcas91 Level 1 (0 points)

    It's not the settings/configuration. It worked before mavericks, and it works on first launch of mail (at least for me). Now with updated firewall settings (see above), everything is worked as expected.

  • dcrowder1 Level 1 (0 points)

    This worked for me!

  • FriarOP Level 1 (0 points)

    I am having the same problem. Running two iOS devices (iPhone 5s and iPad Mini w/ retina), three Mavericks devices (Macbook Air, iMAc at home, iMac at work). Mac Firewall is (and always has been) turned off for all Mavericks devices. Still having a problem with Gmail indicating when an email has been read on another one of the devices.

     

    I've rebuilt the mailboxes, etc.

  • marcas91 Level 1 (0 points)

    Is it still working? Unfortunately, mine stopped. I think it was while my Mac was asleep... woke it up and had 14 unread in my Inbox, as well as mail that had been archived still there. I manually synchronized the changes with my iPad, and it's keeping up now... firewall didn't fix it this time.

     

    Are you having the same "luck"?

  • guitrein Level 1 (5 points)

    Same problem here. Why isn't Apple addressing these problems? It is pretty serious in my opinion!

  • mumbles2701 Level 1 (5 points)

    ive got the same problem. IMAP syncing was working perfectly across MBHP, Mini and iPhone 5... and i thought it was on Mavericks. Its only thisweek things appear to have gone wrong. It only appears to be my inbox, differing emails, differing read emails, multiple emails on iphone only.

     

    Odd...

     

    This:

    http://support.apple.com/kb/HT6030

    i believe is now in the software updates and both OS machines have it applied..

  • TomHK Level 1 (0 points)

    Same here, a week ago I could right click on a mail account and click on Synchronize "account name" to get the messages downloaded but now it doesn't even do that anymore, I have to quite mail app and restart it to get the latest messages.

     

    I don't have this problem with my gmail account, these messages just keep coming in, it's only with other Imap accounts.

     

    Very frustrating as I now have to constantly check on my phone if a new message arrives and restart my mail app when it does.

  • Dr. Mo Level 1 (0 points)

    Hi everyone,

    I had the same issue. Also, I have AVAST installed. I tried the folliwng

    After removing the tag from Mail in avast preferences and restartingthe mail app, i got the mail app synchronising

    Hope it helps.

  • merqlove Level 1 (0 points)

    1. OSX firewall enable via OSX preferences,

    2. add Mail,

    3. OSX system firewall disable via OSX preferences

     

    Also working for me.

    I'm using Little Snitch as firewall.

Previous 1 2 3 4 5 Next