Previous 1 2 3 4 Next 54 Replies Latest reply: Apr 11, 2015 12:09 AM by russ84 Go to original post
  • rhirons Level 1 Level 1 (0 points)

    Just want to chime in with my findings.

     

    I'd tried all the fixes. Disabling power saving feature, removing all extensions, resettings safari and clearing all website data.

     

    I booted into guest mode and safe mode and was still getting terrible performance. I was also getting poor performance across all browsers (google chrome and firefox).

     

     

    My solution:

    I had sophos antivirus installed. As soon as I removed this pages were instantly loading and 10x more responsive. Might be worth a try if you have this installed and are having safari issues. I'm off to find a new anti virus program!

  • sheebz44 Level 1 Level 1 (0 points)

    Thanks Rhirons, killing Sophos fixed my slow Safari problem as well.  Like you I tried the previous fixes with no luck, and also experienced slow load times regardless of Safari or Chrome.  After removing Sophos now loading with much better speed, very much appreciated for your insight.

  • rhirons Level 1 Level 1 (0 points)

    Glad it worked for you as well sheebz44! I've not had any issues since removing Sophos.

  • pdb206 Level 1 Level 1 (0 points)

    Thanks for the tip on ipv6. I swear, for all the hype, it hasn't made a bit of difference to me. Maybe it's misconfigured here, I don't know. But your tip makes a difference.

  • g.d.williams Level 1 Level 1 (0 points)

    For me the issue was Trusteer Rapport - uninstalled this and everything started working fine.

    See also Re: Safari quit unexpectedly while using the librooksbas.dylib plug in - this error message showed up, and Safari stopped working entirely, after I deleted the cache, as suggested at the start of this thread. 

    Rapport also appeared to stop Firefox (v. 30) working.

  • megaram Level 1 Level 1 (0 points)

    Thanks Rom. I do not want to say definitively that Rom has solved the solution for everyone posting here. I can confirm unchecking the box to Stop Plug-ins in preferences under the Advanced tab has worked for me. All pages are loading quickly again in Safari 7 on Mavericks.

  • TaMz6 Level 1 Level 1 (0 points)

    Thanks for the tips g.d.williams, my slow issues on safari 7 (version 7.0.6 (9537.78.2)) / OSX Maverick 10.9.4 seems to be due to Trusteer Rapport.


    I have trash the extension mod  and everything seems to work fine now. Safari is running much faster with all websites I use regularly

  • Surfink1963 Level 1 Level 1 (0 points)

    It would seem that there are a number of issues that can be causing this problem (websites loading very slowly or not at all, progress bar hanging up and freezing). I tried booting into Recovery mode and repairing permissions and reinstalling Mavericks, several times each, with no luck. Finally, after reading further through this thread, I delved into the Plug-Ins and Extensions in Safari Preferences, and, short story shorter, it turned out to be an incompatible extension called Greenhouse. I uninstalled it, and Safari is zipping along like it should. We'll see how long this lasts—I thought it was fixed after repairing permissions a week ago, only to have the problem return today. But, so far, it looks like things are back to normal. Just my two cents, but that's all it was for me. I would suggest trying the Plug-Ins and Extensions route before going through all the other gyrations, it might just be that simple. Thanks to all who posted here, saved me a call to tech support.

  • russ84 Level 1 Level 1 (25 points)

    This helped great with Safari loading quickly. Thanks

  • russ84 Level 1 Level 1 (25 points)

    Thanks, your instructions also helped to get Safari to load fast.

Previous 1 2 3 4 Next