11 Replies Latest reply: Nov 13, 2013 4:43 PM by C F McBlob
Gerhard1959 Level 1 (0 points)

I have a USB Device San Disk Cruzer 16GB and when I connect to my Mac Mini (bought recently) it isn´t shown on my Mac. The Mini has four USB 3 ports and the device I do believe isn´t USB 3 but USB 2. Still I think it should work but it simply doesn´t. What do I have to do?

 

thanks for any help


Mac mini, OS X Mountain Lion (10.8.5)
  • lllaass Level 10 (175,790 points)

    How is it formatted?

    Does it show on another computer?

    Does it show in Disk Utility?

    Does it show in System Report for the Mac under USB?

  • Gerhard1959 Level 1 (0 points)

    It ran without any problem on my old Dell PC. It doesn´t show up neither in Utility nor in System Report

  • Michael Black Level 7 (20,392 points)

    Do other things plugged into that same USB port work properly?  In other words, is it the port, or the device?

  • Gerhard1959 Level 1 (0 points)

    I use two other ports and they work with my mouse for example. I thought maybe there is something wrong with the other ports so I stuck the USB stick into one of the ports which worked and the USB still doesn´t work or show up in System Report. I do know that it works so because just last week I used it on a Laptop. I need to check up on some info I have stored on that device.

  • lllaass Level 10 (175,790 points)

    I would try it again on the laptop. Maybe it died.

    Also, does the USB port on the Mac reconize any USB mass storage device (e.g., external HD)? Maybe there is a problem with the Mac?

  • Gerhard1959 Level 1 (0 points)

    I just tried the USB device on the Laptop and it works without any problem. I put another USB stick (empty) into the Mac and it didn´t show up in System Report. When I took it out I was told that I didn´t correctly remove the device which surprised me. The only two things which show up are the mouse and the keyboard.

  • Gerhard1959 Level 1 (0 points)

    Does anybody have another idea? What about downloading an USB driver? If yes, which one? Like I said before, any help would be great. Thanks

  • Michael Black Level 7 (20,392 points)

    You should never need any 3rd party driver in OS X.  I have a whole bundle of USB sticks (companies give them out at meetings all the time) as well as ones I've bought myself in up to 32GB capacity and all of them work just fine in OS X (and windows for that matter).

     

    So I still have no idea why yours is acting the way it is, but it is not a driver issue.

  • Gerhard1959 Level 1 (0 points)

    Thanks Michael, lol, and I haven´t even stuck it the other way round. Well, I guess I have to keep trying my luck.

  • Joe Bailey Level 6 (12,210 points)

    If you are trying to connect through a hub, try connecting directly to a port on the Mac. If that doesn't work try another port on the Mac. FWIW I spent an hour or so last week trying to get a SanDisk to connect through a USB 3 port. Finally I tried a USB 2 port on a hub and voila it worked perfectly. Several other memory sticks from different vendors work perfectly through the same USB 3 and USB 2 ports.

  • C F McBlob Level 4 (2,865 points)

    WHAT format is the Flash Drive?
    I have Sandisk Cruzers (8Gb, 16Gb, 32Gb and 64Gb) and if I format ANY of them as NTFS, my Mini won't recognize them. Whenever I have to use a flash drive between my PCs and my Mac, I have to use FAT formatting.

     

    Sandisk gave me a file (they make available when you insist on it) a few years back that helps a lot with flash drive formatting. It's a standalone that you can put in your Program Files(x86) folder and run from there. It "deep formats" USB drives, in either NTFS or FAT32.  HPUSBFW.zip

     

    Use that to reformat the flash drive in FAT, and then try it with the Mini.