4 Replies Latest reply: Mar 24, 2014 11:53 AM by ryanbrodie
LiquidD316 Level 1 Level 1 (0 points)

Hey All,

 

I wanted to share an issue and solution that may help someone else. I installed Mavericks on a 2010 27" iMac the day it came out. The issue I had was that the iCloud pane in Pref just locked when opened and com.apple.internetaccounts would eventually stop responding. This would cause Safari not to CMD+Q properly and just hang. Mail couldn't close (not hang), but worse, I couldn't do ANYTHING with my iCloud account. I deleted or moved mail, and it would just reappear. This problem plagued me since that day and I could find no real solution. Rebooting was the only thing that cleared it, but it would happen again later on. Sometimes it would be fine for a few hours after reboot, other times reboot wouldn't help until a second or third reboot.

 

I created a new admin user account and moved everything over. All was fine for 8 hours and it happened again.

 

Last night when it happened I forced quit com.apple.icloudhelper in the Activity Monitor, on a whim. It restarted itself and the pane worked again! I opened the Activity Processes and clicked the helper to see open files and ports. I compared the file sizes and info of all files associatied with it to my working Macbook Pro. User/Library/Caches/com.apple.icloudhelper folder was a different size. I couldn't open the database files, so I copied them to my desktop, put my Macbook Pro folder in its place and restarted the process.

 

It worked all night and through today except one lock up and force quitting com.apple.icloudhelper fixed it. I don't think it fixed it completely as this may need a bigger fix in an update, but this worked for me and hopefully someone else until a final fix comes. BTW, I don't use the iCloud Keychain, but don't think it would matter. I may later, but not now.

 

Now, hopefully, I can enjoy Mavericks like I was supposed to. Take care.


iMac, OS X Mavericks (10.9)