4 Replies Latest reply: Feb 3, 2014 9:40 PM by RFW4274
FCarenborn Level 1 Level 1 (0 points)

Hi,

 

I have 10+ HP Laserjet PRO 400 COLOR M451NW in different classrooms at my school. All the students have iPad 2. We use the feature *HP Wireless direct printing to control printing and it stops prank prints and what nots. All HP printers have the latest firmware version.

 

*HP wireless direct printing is a feature that allows you to print directly to your HP printer without a network, using a direct peer to peer wireless connection. Just connect to the printers own SSID and you'll find the printer in AirPrint.

 

Issue

After update to iOS 7.0.3 this feature stop working. You can connect to the printers SSID and the ipad get's a IP-adress but the Wi-Fi symbol at the top left dosen't turn on. It's like the iOS dont understand that it's connected. Therefore no printer show up in AirPrint. This feature still works on iOS 6.

 

If I use a iPhone or iPad with cellulare connection and with iOS 7 airPrint finds the printer and the feature works fine.

 

So the problem lays in iOS 7 and it's like it dosen't even bother searching for the printer because the it has no Internet connection from the printers own Wi-Fi SSID.

 

 

Apple pleas, fix this soon.

 

..And no, we wont configure our printers on the schools main Wi-Fi network because it's not practical workable and we have no printing control. If there were a passcode lock for AirPrint feature we could use it.

 

Thanks

 

Best regards,

IT-administrator

Sweden


iPad 2, iOS 7.0.3, Wi-Fi
  • 1. Re: HP wireless direct printing in iOS 7
    Handratty Level 1 Level 1 (0 points)

    Thanks for asking Apple to fix this: Same issue here! While access of the iPhone through Wireless Direct or via Wi-Fi network is ok,  the iPad2 with either iOS 7.0.3 or iOS7.04 is kept out. None of the available suggestions of HP or in forums solved the problem.

  • 2. Re: HP wireless direct printing in iOS 7
    ticousa Level 1 Level 1 (0 points)

    i have exactly same problem, the weird thing is i do have one the is black and white, hp  laserjet p1102w connected like that with connect direct and the ipad works with it, but with my hp laser pro200 color and wont work, but if i use my wifes ipad ios 6  works, also like you side works with iphone with ios 7, i used on my car and i love it,  see but when you call apple they dont know about it, theyr like so yuor router have signal, then you have to explain how the system works, cant believe it, when ios7 came out i did the upgrade to my ipad and i told then, i do use it everyday to work, i do and print my estimate on the spot, i need a solution , and they gave me a new ipad, they told me just dont do upgrades, i was like ok,  but was some files wasn't compatible so ipad keep asking for update so i did, a couples days ago, thinking now is 7.0.4  but dont work, so i call and they told me, if works with one of your printer and not with the other printer call hp , so now i going to do that see what they said

  • 3. Re: HP wireless direct printing in iOS 7
    RFW4274 Level 1 Level 1 (0 points)

    I have a similar situation.  I have an HP Photosmart 7525 which is connected via wifi to my router-based network and I also have wireless direct enabled for the printer.  We have desktop and notebook computers using the printer via the router and iphones using the wireless direct without any problems.  My wife has printed many times with her iPad 2 (with iOS 7) without any problems but recently it quit working.  A print job stalled after printing only one of two pages.  I found that the wireless direct had been turned off at the printer so I cannot figure out how the job started to begin with unless it was somehow going through the router.  At the time I did not know how to clear stalled print jobs.  I powered down EVERYTHING (computers, iPad, router, and modem) and brought everything up a piece at a time re-enabling the printer's wireless direct before restarting the iPad.  No help - iPad reports that printer is no longer available when print jobs are sent to it.  The iPad "sees" the printer and connects to it.  I tried "forgetting" the wireless printer connection and re-discovering the printer.  This did not help.

     

    I think the iPad is detecting the presence of the printer on the router network and trying to connect that way but the iPad does not have an app or printer driver for doing so.  Is it possible to force the iPad to use the wireless direct (airprint) connection once it has detected the printer on the router-based network?

  • 4. Re: HP wireless direct printing in iOS 7
    RFW4274 Level 1 Level 1 (0 points)

    I found a solution for my situation - don't know if it will be helpful for others in the discussion...

     

    When mobile devices "look" for available networks they apparently detect my HP printer as an entity connected to my wireless network (router-based wifi).  If that one is selected, the mobile device apparently uses a generic/default printer driver which may not work correctly or consistently with the printer.  I had the mobile device "forget" the existing printer connection which was not working.  Then instead of selecting the detected printer, I tapped on "Other", typed in the full printer wireless network name, then tapped "Join".  The mobile device "found" the wireless direct connection and connected using the next available IP address (the printer itself is always 192.168.223.1).  Devices connecting to the printer take address 192.168.223.100 and upward.