6 Replies Latest reply: Dec 25, 2013 12:24 AM by vletm
vletm Level 1 (0 points)

No need to disable additional languages! Just active 'British' keyb and back to 'Japanese'. It works. But why gotta do this way?


OS X Mavericks (10.9)
  • Tom Gewecke Level 9 (77,200 points)

    It's Apple's new system -- Kotoeri uses the last used keyboard, and for a JIS keyboard this has to be US or something similar.  Tell them you want it back the way it was in 10.8 and earlier via

     

    http://www.apple.com/feedback

  • Tom Gewecke Level 9 (77,200 points)

    10.9.1 has

     

    • Addresses an issue that may cause Japanese keyboards to retain a previously used language
  • vletm Level 1 (0 points)

    I told them ...
    Still, this looks wierd ... everything looks that it should work as long time ago (You see 'the right mark for keyb' but ... then You'll write ... no good!) It cannot be Okay, if You can see that You could write with Japanese-keyb but the result is something else. How I can be sure that the text that I'll start to write would be correct? There are many cases that I have to write with both keybs in same text. ... or is there some great idea to reset keybs after everytime ... many times in one text?  I hope that You could understand this and more better if You could help to solve this. @>->--

  • Melophage Level 5 (7,140 points)

    vletm,

     

    have you tried running Software Update to go to 10.9.1, per Tom Gewecke’s reply, to see if that fixes your problem?

  • Tom Gewecke Level 9 (77,200 points)

    vletm wrote:

     

    I hope that You could understand this

     

    No, your description is to confused.  Please upgrade to 10.9.1, make sure Kotoeri Preferences are set the way you want for Keyboard Layout, and then come back and let us know what is not working right.

  • vletm Level 1 (0 points)

    こんいちは

     

    I'm back. I have upgraded to 10.9.1 and tested ... tested.

    I didn't want to answer before I was more sure that ...

    upgrade seemed to work better or ...

    actually,

    I haven't found any mistakes anymore with this (keyb layout).

     

    Nowadays, it seems that then I choose and write with British, Finnish, Romaji and Hiragana -keyb layout

    those seemed to work as those should work ... in common sense ... with any combination.

    (like British asdfghjkl;'\ Finnish asdfghjklöä' Romaji asdfghjkl;'\ and Hiragana あsdfghjkl;’\)

     

    Testing ... testing ... it will take time as I have noticed and

    sometimes some upgrades will change something unwanted again.

     

    But now, this seems to work as fine as possible.

     

    Thank You, kiitos, ありがとう