Skip navigation

itunes store causes itunes to crash windows 8

5783 Views 20 Replies Latest reply: Mar 12, 2014 4:45 PM by SoftwareConnoisseur RSS
  • tmwest62 Calculating status...
    Currently Being Moderated
    Feb 7, 2014 7:02 PM (in response to tml387)

    It did not fix mine.    What next?  I also added the "dll" to the "Pathext" and did not work.  The following is details to the error I am getting upon crash...does it have something to do with "Fault Module Name"?

     

    Problem signature:

     

    Problem Event Name: APPCRASH

    Application Name: iTunes.exe

    Application Version: 11.1.3.8

    Application Timestamp: 5274a87d

    Fault Module Name: WebKit.dll

    Fault Module Version: 7537.60.11.29

    Fault Module Timestamp: 52f34882

    Exception Code: c0000005

    Exception Offset: 00050d98

    OS Version: 6.1.7601.2.1.0.256.48

    Locale ID: 1033

    Additional Information 1: 0a9e

    Additional Information 2: 0a9e372d3b4ad19135b953a78882e789

    Additional Information 3: 0a9e

    Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

     

  • PPetra Calculating status...
    Currently Being Moderated
    Feb 8, 2014 6:45 AM (in response to tml387)

    still not working for me

  • David Lynch Paris Calculating status...
    Currently Being Moderated
    Feb 8, 2014 10:27 AM (in response to PPetra)

    For me it was different of this tip but it works anyway.

    1) You have to locate the file QTmoviewin.dll

    2) Input the path of this .dll file in the PATH variable

    If you didn't, you will need to install quicktime from the itunes setup program.

    Restart and it should work.

  • SoftwareConnoisseur Calculating status...
    Currently Being Moderated
    Mar 11, 2014 9:52 PM (in response to tml387)

    On my Windows 7 x64 system the QTMovieWin.dll file is in the folder E:\Program Files (x86)\Common Files\Apple\Internet Services. On someone else's system, this might more likely be C:\Program Files (x86)\Common Files\Apple\Internet Services. However, adding this folder to the system Path did NOT fix my problem. iTunes continues to crash on attempting to access the iTunes store. My problem IS identical to that reported in this thread, down to the same displacement within the WebKit module.

     

    I also tried coping the QTMovieWin.dll file to the folder containing iTunes.exe. Doing so caused another sort of error on program launch. I infer that QTMovieWin.dll IS being access by iTunes.exe, exactly as claimed in this thread. However, other files in the same folder are also accessed so it's important to modify the Path as directed rather than merely copy a file or two. I infer that, in the case of Windows 7 x64, the suggested fix may not be quite right. At least, I suppose that's the reason it failed in my case. Further experiments pending. I'll report anything that works or looks promising.

  • David Lynch Paris Level 1 Level 1 (0 points)

    It works on Windows 8 64 bits. May be you will find a topic about itunes on Windows 7. Or maybe it work work by uninstall, reboot and reinstall quicktime. Let us know.

  • SoftwareConnoisseur Level 1 Level 1 (0 points)

    David, I had previously tried the uninstall-delete-reinstall procedure multiple times and only doing so did I discover this thread. That said, perhaps because of your reply, I decided to do it again. When I first launched iTunes after the reinstallation both the iTunes store and the discussion list were down. But after service was stored I can once again access the iTunes store. I have no idea what step or STEPS (???) actually fixed my problem. But, at least for now, it's gone.

     

    BTW, I am running 11.1.3 rather than the current release. The current release freezes for some minutres when a track is selected--or at least it did. I observed that problem several times during this troubleshooting match. The generally recommeded fix for that problem is . . . you got it! . . . uninstall, delete, and reinstall. I'll go instead with "discretion is the better part of valor" and skip the current release.

     

    Thanks to all!

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.