Previous 1 2 Next 21 Replies Latest reply: Nov 27, 2014 7:58 AM by Doctor Ralph
Rafael Perini Level 1 Level 1 (10 points)

Annoying bug when editing images using Nik Plug-in collection and Aperture 3.5.1/Mavericks: Once you save the image and go back to viewer mode, the viewer is grey only. Interestingly, if you open the loupe, you see the image through it. Unfortunately you cannot see any other image on the viewer (edited or not with Nik). After restarting Aperture, everything comes back to normal.

 

Here is my workaround:

 

Do NOT start the plug-in from the viewer mode, but rather from the Browser mode (right click on the image: edit with plug-in, then the Nik Plug-in (Silver Effex Pro 2 for example). Once you save the image and you are back into Aperture, then you can enter the Viewer mode without getting the Grey Screen Bug!

 

Seems that the bug is related to generating the preview after editing with Nik.

 

Hope that helps

 

Raf

 

ps. this is working on a fresh install of Mavericks on a rMBP, Aperture 3.5.1 and Nik Collection version 1.108


Aperture 3, OS X Mavericks (10.9), Nik Plug-in
  • IceWolf08 Level 1 Level 1 (5 points)

    Well, I am having the same issue. I appreciate that you found a work-around, it is a little annoying.  I wonder who broke this, Apple or Google....

  • Rodney9 Level 1 Level 1 (10 points)

    Thank you Rafael, hopefully the next update will fix this.

  • hval Level 1 Level 1 (0 points)

    Rafael,

     

    Thank you for information.  I have been driven to distraction trying to work out what has gone wrong.

  • LaMaxinfo Level 1 Level 1 (0 points)

    Same boring problem here.

    the problem seems to be related to the Nik efex suite. I have installed the OnOne suite and the plugin works without any issues.

  • marc.hb Level 1 Level 1 (0 points)

    I had the same problem but with a little "bonus feature". After I used one of the NIK plugins and open another image Aperture says "no compatable file" (triangle with an exclamation mark in it). For my luck I saved the old installer and now I just installed the old version and ervything works fine again.

     

    Thank you Google. For myself I can say for sure that this time it's Googles fault.

  • Bruce Sanderson Level 1 Level 1 (70 points)

    I have found that using Time Machine to restore a previous version of Silver Effects Pro (2.1) in place of version 2.2.0.8 brings back "normal" functionality at least so far.  Curiously however the SEP get info panel still reports the existance of the later version rather than the earlier one.

  • mtb_monster Level 1 Level 1 (35 points)

    Hi, I was experiencing the same issue with Mavericks, Aperture 3.5.1 and the latest version of the Nik / Google collection plugins. I found that after returning from Color Efex Pro that there was a thumbnail of the version, but that viewing the image in the browser just showed the grey screen.

     

    Switching back to the browser, selecting the affected image and then invoking the "Generate Preview" command (Aperture Photo menu & hold down the alt/option key) worked for me.

     

    However, since doing this once I am unable to replicate the grey screen effect wth Color Efex Pro, Silver Efex Pro or Analog Efex Pro.

     

    Hope this helps

     

    Adrian

     

    Message was edited by: mtb_monster - correction to poor grammar

  • hval Level 1 Level 1 (0 points)

    mtb_monster,

     

    Thanks for your information.  Unfortunately it hasn't worked for me.

  • mtb_monster Level 1 Level 1 (35 points)

    This is peculiar, I've now repeated the process on my main Mac (mid 2011 27" iMac on 10.9, Aperture 3.5.1 & latest Nik Collection) and I was met with the grey screen after taking an image to Color Efex Pro. This time I was initally unable to get the preview (re)generated or to delete the preview. To make matters worse I was unable to view any images in the Viewer. I selected 5 projects at random and could not see any preview images within the Viewer.

     

    I quit and restarted Aperture (only not my Mac) and returned to the orginal image I had taken to CEP. In the Viewer it tooks 30 seconds or so to generate a preview and then there it was, no grey screen. All other projects had previews as per normal.

     

    Now that the preview has been generated I also tested taking other random images out to Silver Efex Pro and also Analog Efex Pro. Previews generate quickly and the original behaviour with the grey screen cannot be replicated.

     

    Hope this helps. It would be interesting to know if other people have similar experiences.

     

    We are not alone - another thread here

     

    Message was edited by: mtb_monster : added link to other thread

  • clallo16 Level 1 Level 1 (0 points)

    Good morning all,

    I have the same problem and all the solutions you indicate doesn't work.

    I have aperture 3.5.1 and Nik Plug-in collection but when I use it (for example Color Efex Pro 4) to modify an image and I save it appear a grey screen and I have to restar Aperture because doesn't work for any other images.

    Someone found a solution?

    I use Aperture from 4 years and never happen something like this!

    I have a latest 27 inch Imac 2,9 ghz core 5

  • Andreas Krone Level 1 Level 1 (5 points)

    Same problem here. But most of the time i don't get a grey screen but a red or brown one. Depends on the colors of the picture. Sometimes it shows quadratic parts of the image or clusters of parts. Strange.

  • marc.hb Level 1 Level 1 (0 points)

    I read a post in another forum where a user suggested first to repair and then rebuild the library file. For me it helped and I can now use the plugins without any problems.

  • Andreas Krone Level 1 Level 1 (5 points)

    I'll try this now

  • clallo16 Level 1 Level 1 (0 points)

    I disinstalled and reinstalled Nik plugings and now it seems to work better.

    The grey screen arrive just sometimes...

    I tried to repair and rebuild but nothing changed!

Previous 1 2 Next