Previous 1 2 3 4 Next 184 Replies Latest reply: Jun 9, 2014 11:38 PM by kannankvs Go to original post Branched to a new discussion.
  • kappalamda Level 1 Level 1 (0 points)

    I am experiencing the same issue. Since i upgraded to ios 7.0.4, i cannot connect to my home wifi with my router being just 3 meters from my iphone 4. On the contrary, wifi connection worked ok with 7.0.3, although there were issues with  finding wifi connection on the air. Anyone has any clue if apple is working on 7.0.4 wifi disaster?

  • GJS99 Level 1 Level 1 (0 points)

    Last night I upgraded my iPhone 4s from iOS 7.0.3 to 7.0.4 and am now experiencing the same problem.  Choose a Network lists my network (as well as those of my neighbours) but clicking on my network results in the "Unable to connect to network" message.

     

    Fixes tried:

    • Turned wifi off and then back on (tried several times)
    • Restarted iPhone (tried several times)
    • Reset iPhone (tried several times)
    • Clicked Forget this network, then tried to reconnect (verified password is correct)
    • Tried Reset Network settings
    • Restored from backup done prior to iOS 7.0.4 upgrade

     

    Background:

    • Never had any problems with wifi connectivity on iOS 7.0.3 or previous versions of iOS – was able to connect to home wifi network and others
    • Upgraded to iOS 7.0.4 via iTunes last night.  Upgrade executed without issue (no warnings or error messages)
    • No firmware update is available for my router
    • Other devices can still access my home wifi network without issue (wii, laptop, blackberry, 2 other iPhones and 1 iPod running older versions of iOS)
  • abalboni Level 1 Level 1 (0 points)

    I'm having the same issue after the update with my 4s as well. I've also tried all of the suggested fixes. In addition, it seems like it broke a few of my apps as well, including facebook, nothing loads properly, can't send messages etc. I've also noticed that when I try to look for new updates in software updates it tells me that there was an error and it's unable to load any updates. This is the first real issue I've ever had with the software updates and I'm beyond annoyed because right now my so-called "smart phone" is usless for basically everything except texing and calling.

  • Noctis Azura Level 1 Level 1 (0 points)

    try this fix

    after looking all over the forums for a solution to this, i decided to try another way. Instead of using your WiFi password, try using your Wireless encryption key instead. As soon as i tried conecting to WiFi on my ipad 2 (just upgraded to ios7) it worked straight away. Hope this helped.

  • GJS99 Level 1 Level 1 (0 points)

    Hi.  Can you clarify what the difference is (wifi password vs wireless encryption key)?

  • peter.stone Level 1 Level 1 (0 points)

    iPads are not affected by this problem plus this problem exists on open networks with no password on both 2.4 and 5 Ghz ranges. I'm terror-lolling inside about how now you may not be able to 'update' online (cell network)??

     

    We're gonna party like it's 1999 again with doing a tethered update aren't we?

  • Noctis Azura Level 1 Level 1 (0 points)

    I am not entirely sure what the difference is between the two, but i know they are very different forms of security. The wireless key should be on the back of your hub box. if not go into your hubs settings and search for wireless key or wireless encryption key

  • Noctis Azura Level 1 Level 1 (0 points)

    Ipads are having this problem, mine was but now fixed.

  • GJS99 Level 1 Level 1 (0 points)

    Update: just got back from Apple store.  Wifi worked fine there.  Explained situation to the attending Genius per my post above.  I was expecting him to blame my router, but he ran some short diagnostic tests and said they were "inconclusive".  Then said "you need a replacement phone".  Good thing I still had 14 days left on the warranty.  Gave me a new phone and I was on my way.  Still have to see if it works with my home wifi network.

  • kappalamda Level 1 Level 1 (0 points)

    The issue with ios 7.0.4 is that my iphone 4 can find and connect to my home wifi only after it is like next to the router like 10-30cm away. It is like apple minimized wifi receptor power. Concequently, my iphone 4 cannot find any wifi connection since i have to almost "attach" it to each router.

  • kcrow05 Level 1 Level 1 (0 points)

    I was having the same issue. Wifi constantly popping up and then not connecting or saying that it couldn't connect and dismiss. i don't know about a hairdryer for a fix but I got mine to work by resetting my phone settings. Not my network settings. Settings>General>Reset>Reset All Settings. This also fixed some issues I had with facebook app not being able to connect to its server or whatever. Hope it helps someone else.

  • Rahul Kulkarni Level 1 Level 1 (105 points)

    Make an appointment with Appl Store, they will help you out if the phone is under warranty!

  • GJS99 Level 1 Level 1 (0 points)

    Update #2: got home after work yesterday and new iPhone will now connect to my home network. This phone is still on iOS 7.0.3, and I will not be upgrading until this wifi BS is resolved. 

  • niftycrackers Level 1 Level 1 (0 points)

    Same issue - 4s on 7.0.4.  Tried it all.  No luck for us.

  • feistmann Level 1 Level 1 (0 points)

    I solved this by turning my router and modem off, waiting 30 seconds, and turning it back on.  I hope this works for others.

Previous 1 2 3 4 Next