Previous 1 2 Next 26 Replies Latest reply: Nov 19, 2013 1:44 AM by PokeXY Branched to a new discussion.
PokeXY Level 1 Level 1 (0 points)

After doing a clean install of Mavericks and getting back all the data from a time machine transfer. I can update all the software fine for example imovie and iworks and all the apps, I did that at my school.  But then I find when I am at home I can still update all the apps but when it comes to system update like mail or firmware, it comes up as Didn't get a response from the Software Update sever (10.60.8.40). I figure out that my mac is trying to contact the school sever but can't at home. But then when I am at school the school's sever don't offer the newest update which is faustrating, I like to keep up to date as soon as possible.

 

Before I upgrade to mavericks, I had mountain lion. Everything runs fine, it uses the school sever and the public sever when I am at home to update, it worked seemlessly, but now it keep trying to contact to school but not the public one. How can I reset the setting and set it to the public sever. I try delting the file com.apple.SoftwareUpdate.plist like some website I search up said. But that didn't change anything.

 

Please help

 

Screen Shot 2013-11-17 at 4.51.48 pm.png


MacBook Pro, OS X Mavericks (10.9), Late 2011 2.4ghz i5 16Gb RAM
  • Error-free IT Level 1 Level 1 (20 points)

    Hello PokeXY,

     

    Try the Terminal command:

    sudo defaults delete /Library/Preferences/com.apple.SoftwareUpdate CatalogURL 

     

    Source

  • PokeXY Level 1 Level 1 (0 points)

    it didn't worked... I saw this on one of the website before. but I copy yours anyway and it came up with this.

     

    2013-11-17 18:46:54.034 defaults[5744:507]

    Domain (/Library/Preferences/com.apple.SoftwareUpdate) not found.

    Defaults have not been changed.

    192-168-1-104:~ yexua$

  • Linc Davis Level 10 Level 10 (173,925 points)

    Is there a preference pane named "Profiles" in System Preferences? If so, then some settings have been locked and you can't change them yourself.

  • PokeXY Level 1 Level 1 (0 points)

    No... there is no 'profiles' section in the system preferencesScreen Shot 2013-11-18 at 1.00.17 pm.png

  • Linc Davis Level 10 Level 10 (173,925 points)
    Please read this whole message before doing anything.

    This procedure is a diagnostic test. It’s unlikely to solve your problem. Don’t be disappointed when you find that nothing has changed after you complete it.

    The purpose of the test is to determine whether the problem is caused by third-party software that loads automatically at startup or login, by a peripheral device, or by corruption of certain system caches.

     

    Disconnect all wired peripherals except those needed for the test, and remove all aftermarket expansion cards. Boot in safe mode and log in to the account with the problem. Note: If FileVault is enabled on some models, or if a firmware password is set, or if the boot volume is a software RAID, you can’t do this. Ask for further instructions.
       
    Safe mode is much slower to boot and run than normal, and some things won’t work at all, including sound output and  Wi-Fi on certain models. The next normal boot may also be somewhat slow.

    The login screen appears even if you usually log in automatically. You must know your login password in order to log in. If you’ve forgotten the password, you will need to reset it before you begin.

     

    Test while in safe mode. Same problem?

     

    After testing, reboot as usual (i.e., not in safe mode) and verify that you still have the problem. Post the results of the test.
  • PokeXY Level 1 Level 1 (0 points)

    Nothing changed. It still came up as didn't get a response. I don't know if this make a difference but when it said didn't get a response. It comes up twice, either in safe mode or not. I click ok first time but it bounce back the second time and I have to press ok again.

     

    I don't know but I think this problem have to do with when I first got this mac, it came from my school. The IT must have changed the preference before they given it to me to update from the school sever because some of my friend's laptop are like that, can't update from home. They didn't really bother to ask why but mine has always been fine, school or home, no problem. So yeah I think it is in the setting somewhere in my mac.

     

    When I deleted everything and clean install mountain lion, it still worked fine, just now mavericks.

     

    I am no expert so your input is still really value to me to fix this problem but I was wondering if I do a clean install of Mavericks again but when I get back all my data from time machine, I don't restore the setting to the update sever. Would that make it back to the public sever? I don't know how to do it though...

     

    It is fine if I don't update from school, the school sever is useless... it provide the same update as the public one but get them like 2 months later...

  • Linc Davis Level 10 Level 10 (173,925 points)

    If you bought the computer used, you should have erased the internal drive and reinstalled the OS before putting any of your data on it. I suggest you do that now, and then restore only your documents from a backup. Reinstall all your other software from downloads or original media.

  • Error-free IT Level 1 Level 1 (20 points)

    Linc Davis is right, you should erase the hard drive and reinstall OS X.

     

    Before you do anything make sure you have a current Time Machine backup of your data.

     

    You can then follow this guide to create a Mavericks USB installer. Once booted from the Mavericks USB installer open Disk Utility and erase your internal hard drive (usually labelled: Macintosh HD). Then go ahead and install Mavericks. Duiring the setup it will give you the option to restore your applications and documents from your Time Machine backup.

     

    Let me know if you need anymore help.

     

    Thank you,

    Michael

     

    <Link Edited By Host>

  • PokeXY Level 1 Level 1 (0 points)

    Thank you for the advice but this mac was not second hand it was brand new, is just the school bought about 50 of them at the same time and I have always erease everything when every a new os comes out.

     

    Ok I will try ereasing it again but this time I won't restore the settings as well, I have always restore literally everything including settings because there are setting like lot and lot of router passwords I can't be bother recording them manually and more importantly Adobe Master Suite CS5.5, I don't have the original media for that because the school put it on as volume license under the school before they gave me the mac.

     

    I will reinstall it this weekend, but is there an other to this? Is just the update sever, do it really require an reinstall? I can provide any info about my mac to help solve this, please advice me to do so, is just I am not sure what to provide right at the beginning. Or if there is no other way, I will erase it this weekend, when I don't require my mac for school.

  • Linc Davis Level 10 Level 10 (173,925 points)

    You might be able to reset the update server by deleting everything in the folder /Library/Managed Preferences, if it exists.

  • PokeXY Level 1 Level 1 (0 points)

    I delete all the managed preferences, that did nothing but I install the profile Error-free IT gave me and it seem to worked, it doesn't say can't contact the update sever anymore.

     

    But it saids no update avaliable, but that is probably my mac is update already although I never install the mail update for mavericks or Digital Camera RAW Compatibility 5.01, aren't those avaliable for my mac? i have mavericks and iPhoto 11...

     

    Anyway thank you for all you answers, it seem fine now but yet I am still concern that even though it doesn't say it can't contact anymore, it is not showing signs of being able to update either... Aren't DCRC 5.01 and mail update avaliable for my mac? I know I can download from the website but that just defeat the purpose of fixing the problem.

  • Linc Davis Level 10 Level 10 (173,925 points)

    What is "Error-free IT?"

  • PokeXY Level 1 Level 1 (0 points)

    The other person who reply in this discussion above

     

    Screen Shot 2013-11-19 at 6.01.00 pm.png

  • petermac87 Level 5 Level 5 (6,750 points)

    This by the looks of it.

     

    http://errorfreeit.com.au

     

    I won't be downloading anything suct as that, I'm afraid.

     

    Pete

Previous 1 2 Next