12 Replies Latest reply: Mar 3, 2014 8:58 PM by JohnnyDeLuxe
tangeltingel Level 1 Level 1



I have just updated to Mavericks a few days ago. Now I have a strange problem.


The setup with Exchange 2013 works fine ... so I can send&receive mails.


The problem: I only get new mails. All (few thausand) mails stored on the Exchange account are not synced to mail?!


Maybe anyone has an idea how to solve this ...





MacBook Pro, OS X Mavericks (10.9)
Reply by LowLuster on Nov 19, 2013 2:02 AM Helpful

Do yourself a BIG favor. Just stick with Outlook because Mac Mail.App is &*^%$#.

All replies

  • tangeltingel Level 1 Level 1

    Well, correct. That is what I reported ...


    But imho this is a must have ... there is just no way around having access to all my mails. How am I supposed to work with this program if I cannot use all data I have?


    I luckily found out that each account we have with our external exchange provider also includes a license for Microsoft Outlook 2011 for Mac.


    So finally back to Outlook again, which works perfectly fine with exchange.


    But that is not a valid solution for me as long as Mail does offer to handle exchange accounts. If it offered - it has to work. That's why most people are p#++ed of Windows.




  • LowLuster Level 6 Level 6

    Do yourself a BIG favor. Just stick with Outlook because Mac Mail.App is &*^%$#.

  • tangeltingel Level 1 Level 1

    It seems as there is just no way around that.


    Me, as world leading technology company, I'd be embarressed ...


    Time will tell if there will be a solution for this.



    Thanks to you guys anyway. You confirmed what I was afraid of.



  • LowLuster Level 6 Level 6

    If you broswe these forums for Mac Mail problems you will be amazed at the number of posts and problems encounter everyday. Not to say other Mail program don't suffer from some of the same problems but it just seems Mail is more prone to failing in  one way or another on a daily basis.


    In switched years ago to Outlook and haven't had one problem with it through 3 versions of OS X. Lion, Mt lion and now Mavericks.

  • Linc Davis Level 10 Level 10

    I posted a link. A link is something that takes you to another web page when you click it. Try that, and follow the instructions.

  • tangeltingel Level 1 Level 1

    Tried ... didn't work ...


    I actually did this before following your 'link', but without any changes in the inbox ... or any other folders. And I don't even have any other mailbox I could select, so this shouldn't be a problem.


    As LowLuster already posted, there are loads of people complaining about this issue ... without any feedback from Cupertino on this ... This platform here was my last hope to find a way.

  • Linc Davis Level 10 Level 10

    Some problems with Exchange mail have been solved by disabling Autodiscovery. If that doesn't work, see below.


    Back up all data. Delete the Exchange account from the Internet Accounts preference pane and add it back. If there's still no improvement, continue.


    Quit Mail. Force quit if necessary.


    Back up all data. That means you know you can restore the Mail database, no matter what happens.


    Triple-click anywhere in the line below on this page to select it:



    Copy the selected text to the Clipboard by pressing the key combination command-C. In the Finder, select


    Go Go to Folder


    from the menu bar. Paste into the box that opens (command-V), then press return.


    A folder window will open. Inside it there should be files with names as follows:


    • Envelope Index
    • ExternalUpdates.storedata


    Move those files to the Desktop, leaving the window open. Other files in the folder may have longer names that begin as above. Move those files, if any, to the Trash.


    Log out and log back in. Relaunch Mail. It should prompt you to re-import your messages. You may get a warning that the index is damaged and that Mail has to quit. Click OK.


    Test. If Mail now works as expected, you can delete the files you moved to the Desktop. Otherwise, post your results.

  • tangeltingel Level 1 Level 1

    Wow ... sounds like real ease of use ...


    I am grateful for your effort to help, really! But as mentioned somewhere here I now have a working solution with MS Outlook for Mac.


    And that was as easy as it gets with exchange.


    This is just not apple-like. Apple always prides themselves to deliver customer orientated, easy to use products ... and they do with most of the stuff they release - but Mail.


    Let's leave it there and see what happens with updates.




  • kipjryan Level 1 Level 1

    I am suddenly having similar problems - Mail with Exchange 2010 worked fine after maverics - for about two weeks, then suddenly I found that I am loosing emails (I know this becuase both my iPad and iPhone continue to work fine). So following advice I decide to rebuild... now I have NO messages beyong 2 years ago... nothing. Telling it to sync exhange does nothing - it starts to look for mail but just stops.  Thousands of mail messages now only available from iPad or web-mail to Exchange server.


    Like others I seem now to have no option but to go to Outlook, which I hate - but I have $$$$m to protect. We went all mac about 6 years ago against the wishes of the parent organisation (and with no tech support) - has been great of course - but this is impssible.

  • kipjryan Level 1 Level 1

    Actually on reading other posts I realise that all this has happened since the latest (8Nov) mail up-date - they may fixed thigs for Gmail but screwed Exchange.

  • JohnnyDeLuxe Level 1 Level 1

    There's other user forums  on this, and one suggestion from Brad has been this, so please try it:


    It sounds like your Exchange server is not properly configured.  Do you have access to Outlook Web Accesss?  If so, use the server fqdn as the Internal and External Server.


    Example:  OWA is https://mail.mydomain.com/owa


    Set the

    Internal Server to: mail.mydomain.com

    External Server to: mail.mydomain.com


    Try that and report back.