7 Replies Latest reply: Dec 13, 2013 10:49 AM by Springo140
louis445 Level 1 Level 1 (0 points)

I just updated my apple tv and get an error regarding HDCP being reqiuired for playback for netflix or hbo go it worked fine rpior to the upgrade


Mac OS X (10.6.8)
  • jeremy_v Community Specialists Community Specialists (2,985 points)

    Hi louis445,

     

    Thanks for visiting Apple Support Communities.

     

    Try the troubleshooting steps below if you're seeing a message about HDCP after updating your Apple TV:

    If HDCP is not detected

    If HDCP authentication does not succeed, you may see one of the following symptoms:

    • A message may appear on your television stating "This content requires HDCP for playback. HDCP isn't supported by your HDMI connection."
    • You may see periodic bands of static, or full screen static, flashing across your TV screen.

     

    If you are experiencing either of the symptoms above, try playing the same content again for at least another ten seconds. If the issue persists, try the following steps until the issue is resolved:

    1. Connect your Apple TV (2nd generation and 3rd generation) directly to your HDTV using an HDMI cable.

    2. Set your Apple TV to sleep mode and turn off your HDTV:
      1. From the Apple TV interface, select: Settings > Sleep Now.
      2. Turn off your TV and wait for about ten seconds.
      3. Turn your TV back on.
      4. Press the Select button on your Apple TV remote to wake your Apple TV.
    3. Some HDTVs may need a firmware update. Consult your TV manufacturer's user manual or online support pages for additional information about how to update your TV's firmware.

    4. If available, try using a different HDMI to HDMI cable, such as an Apple HDMI to HDMI cable, directly between your Apple TV (2nd generation and 3rd generation) and 720p/1080p HDCP-compatible HDTV.

    You can find the full article with these steps here:

     

    Apple TV (2nd and 3rd generation): About Apple TV and HDCP

    http://support.apple.com/kb/HT4428

     

    Best,

     

    Jeremy

  • JorgeCollado Level 1 Level 1 (0 points)

    I've been going through this issue since i upgraded my ATV with Apple's last major upgrade for it. All of a sudden nothing works, Netlfix, or even shows and movies that i have rented and purchased through itunes. This is very frustrating, the fix below that was given by this "specialist" is what apple has on their website to "fix" the problem, it does NOT work! I'm tired of switching cables, turning things on and off, putting it to sleep, switching televisions... nothing works! I spoke to them over the phone and they weren't able to give me a solution to the problem. The only thing that i found online was that the only solution might come with upgrating the firmware of the TV that's connected to the ATV so that it then registers the HDCP content, but since i'm not able to do that with my TV (as are many others out there) i'm stuck, and i refuse to have to buy a new television to resolve an issue that was clearly created by Apple on their last software update. I have an appointment tomorrow with the genius bar at a retail store to see what they tell me. It is very frustrating, i basically have a $100 hockey puck connected to my TV and nothing to show for it. I will come back later with what i'm told tomorrow.

  • Springo140 Level 1 Level 1 (10 points)

    Hi Jorge, same issue for me since 6.0.1 upgrade. Do you have any updates based on your store visit? Longing to use my ATV again.

  • JorgeCollado Level 1 Level 1 (0 points)

    Hi Springo, ok, so at the genius bar they ended up replacing the ATV and giving me another one (i was still under my one year warranty from purchase). The guy said that there were some ATV's that after the upgrade were damaged, having some issues with the way they connected to the WiFi signal and therefore verifing the HDCP content. I hadn't heard anything related to that before so i wasn't sure what he was talking about. Anyways, got home and tried it on my main television and it still wasn't working, however it did work on my newer TV in my bedroom. After i called Apple for the 50th time they told me that the issue wasn't with the ATV but my television and that it needed a firmware update, and after telling them that i had an older TV and i wasn't able to do a firmware update they basically apologized and said that YES, although the error is coming from the latest ATV software update it is something that's "madatory now among several media players for the protection of media piracy". And although i understand this i think it's ridiculous that i would now have to get another TV (which i won't) to be able to use this product. I now had to move my newer TV to my living room to be able to use the ATV in that room. Try connecting it to several TV's to see if you still have the issue, even check to see if your TV can get a firmware update (although i believe only SMART TV's now a days can do that, not sure). The only other solution would be to do a software downgrade, although without a jail break at this time i don't think that's possible. Good luck and please let me know if you find anything else regarding this. Thanks.

  • Springo140 Level 1 Level 1 (10 points)

    Thanks for detailed feedback Jorge!

     

    Unbelievable that without giving any notice before upgrades, they just pretend like nothing and some customers will have to buy new televisions due to changes in regulations. This must be some kind of joke! My ATV is 13 month old and worked like a charm before the 6.0.1 upgrade. It really woories me that a so well established company like Apple just hope that something like this won't hit the street and have consequences to their business in long term. Think about the impact when something like hammers the social channels. If they keep luring their customers like this, their customers will run easily to the next best offer from other parties.

     

    Shame on you Apple, let me have my pre 6.0.1 version back!!!

  • Joseph Sobry Level 1 Level 1 (0 points)

    Hi Guys, I have the same type of problem.

    I think Apple needs to upgrade their latest upgrade (6.0.2) because that is when all the problems started.

    Various symptoms that I noticed sofar:

    ATV will not restart.

    ATV hangs on the wireless network.

    Video proceeds but audio does not and vice versa.

    ATV does not respond to any command from the remote.

    Etc. etc. etc.

    My TV is a Sanyo and works fine.

    There is no way to upgrade the firmware.

     

    Apple please fix this!!!!!  

     

    Message was edited by: Joseph Sobry

  • Springo140 Level 1 Level 1 (10 points)

    Solved by buying a new Sony LED-TV. 6.0.1 upgrade introduced some new HDCP-version which my 6 year old Samsung LCD did not like.