Skip navigation

Having update issues in mac app store

541 Views 8 Replies Latest reply: Nov 26, 2013 5:15 PM by JassMan RSS
mixitloud Level 1 Level 1 (5 points)
Currently Being Moderated
Nov 18, 2013 8:14 PM

What is happening with the Mac app store? I had several updates... I updated... the updates were succuessful.... but then the updates reappear in the app store like I still need to update. I updated the same update 4 times just to see, and they reappear everytime. Is anyone else having this problem? Is there a fix? Hey Apple... are you aware of this problem?

iMac, OS X Mavericks (10.9)
  • Linc Davis Level 10 Level 10 (107,860 points)
  • Linc Davis Level 10 Level 10 (107,860 points)
    Currently Being Moderated
    Nov 19, 2013 8:12 PM (in response to mixitloud)

    Rebuild the Spotlight index. If you try to search now from the magnifying-glass icon in the top right corner of the display, there will be an indication that indexing is in progress.

  • suraj khagokpam Calculating status...
    Currently Being Moderated
    Nov 19, 2013 9:36 PM (in response to mixitloud)

    i am also facing the same problem with apps store, now i find the solution. now try to restart your mac in a safemode. if you don't know how to start it. just follow my instruction.

    1. Restarted your mac

    2. as soon as you heard the sound of starting press and hold untill your grey screen or untill seen progress bar has start. after progress bar is complete,mac will start and it will take little longer, and will be at safemode(see right up corner)

    3. open apps store, press update tap. see problem is still there.mine is work with this restarting in safemode.

    4. after all this, restart your mac in normal way. don't press anything. see the different. good luck

  • Linc Davis Level 10 Level 10 (107,860 points)
    Currently Being Moderated
    Nov 19, 2013 9:50 PM (in response to mixitloud)

    Bring up a search window in the Finder by pressing the key combination command-F. Search This Mac for the name of the application. Delete all outdated copies that are found.

     

    If the search finds no outdated copies, see below.

    You installed a hacked app, originally from the Mac App Store. It contains the receipt for a different app, downloaded using an account that you don't control. You need to identify and remove the hacked app.

    Important: The app you need to remove is not necessarily the one named in the App Store alert. For example, if the App Store says you need to update "Twitter," the hacked app may be "Angry Birds" or something else entirely. Don't make any assumptions about which app you're looking for. To find it, you have to carry out a systematic search.

    Triple-click anywhere in the line of text below on this page to select it:

    kMDItemAppStoreHasReceipt=1

    Copy the selected text to the Clipboard by pressing the key combination command-C.

    In the Finder, press command-F to open a search window, or select

    File Find

    from the menu bar. In the search window, select

    Search: This Mac

    from the row of tokens below the toolbar. Below that is a popup menu initially showing Kind. From that menu, select  Other...

    A sheet will drop down. In that sheet, select Raw Query and click OK or press return.

    Now there will be a text box to the right of popup menu. Click in that box and paste (command-V).

    The search window will show all the App Store products you've installed. Compare those search results with the list of your purchases from the App Store. To see the complete list, you may need to unhide hidden purchases. If any apps were download from the App Store using other Apple ID accounts that you control, sign in to the store under each of those ID's and check the purchases.

    At least one of the items listed in the search window is not among your purchases in the App Store. Move each such item to the Trash. You may be prompted for your administrator password. Empty the Trash.

     

    Log out and log back in. Test.

  • JassMan Calculating status...
    Currently Being Moderated
    Nov 26, 2013 5:15 PM (in response to mixitloud)

    Just wanted to weigh in that I'm having the same problem and it looks to have stared around the same time as you're post Nov 19th 2013. I'm wondering how many other people are having this same problem and if it was triggered by something in the App Store?

    I'm re- indexing spotlight as I write this and will try the restart after it's done. On a side note didn't there used to be a command to reindex somewhere in the dropdown that appears when you serach in Spotlihgt (Menu bar)? Or someplace else? That whole add a folder/delete the folder thing is pretty cheesy.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.