1 Reply Latest reply: Nov 19, 2013 10:23 AM by Niel
lennonxo Level 1 (0 points)

I currently have a old macbook2.1, late 2006... it is running on MAC OS X version 10.6.8... i dont have iphoto on here, and when i go and get it from the app store it says 'can't be downloaded, MAC OS X 10.9 or later required' ....

i have no software updates avalible and just really want iphoto!!! It used to be on this laptop a few years ago, i just want it back!

MacBook, Mac OS X (10.6.8), help help