2 Replies Latest reply: Dec 3, 2013 6:22 AM by ddkilzer
kailashkumarp Level 1 (0 points)

Hello,

 

Form submit is not working in safari for POST method in IPAD 7.0.4 with CoovaChilli server.

 

When ever we send POST request in safari to CoovaChilli server, Safari shows teh message"Safari cannot open the page because the network connection was lost". I have tried using Ajax request and found that for POST request http status code we are getting is "0"(zero),however when same thing I have  tried with "GET" request the http status code is "200 OK" and it is working with "GET" method.

 

Your's help is highly appreciated.

 

Please let us know in case ,if u need any other information.

 

 

Thanks,

Kailash Kumar P


iPad, iOS 7.0.4
  • kailashkumarp Level 1 (0 points)

    Working fine with IOS 6.1 for POST method with CoovaChilli server.

  • ddkilzer Level 2 (305 points)

    It would proably be best to take this question to a developer forum as this is a customer forum.

     

    However, I would suggest filing a bug using <https://bugreport.apple.com/>.  You may log in with your Apple ID.  If you need to turn your Apple ID into a developer account, sign up using the free Safari Dev Center.  After that, you will be able to log into bugreport.apple.com and file a bug in Apple's internal bug database.

     

    Some things you should include in the bug report:

    • Explicit steps to reproduce the bug.
    • A stand-alone test case if possible.  (Sounds like this requires some server-side software to be set up, so instructions on setting that up are required.)
    • A tcpdump of both a failed POST on iOS 7 and a successful post on iOS 6.1.x.  (Make sure to pass "-s 0" to get the full body of every TCP packet.)
    • Information about workarounds or alternate tests you've tried (like the AJAX/XHR test you mentioned above).