5 Replies Latest reply: Apr 13, 2015 8:50 PM by Markus.S
yavuz.efe Level 1 (0 points)



Recently I bought a Macbook Air (Mid 2013) which comes with Mountain Lion OS. And I did clean state Mavericks OS Installation.


I have 2 different usb sticks which are :


32 GB Corsair Flash Voyager GT USB 3.0

64 GB Corsair Flash Voyager GT USB 3.0



When I plug one of these to mac book air (tried 2 ports) wi-fi stops working (it's not disconnecting but do not receive / send any data)

Also when wifi is disconnected or i try to connect  a wifi (when usb stick is plugged) i always encounter same error (Something Like Connection Time Out)


I'm a Mac newbie. I don't know much about macs.


( I Also Have Kingston DataTraveler Hyper X 8GB USB 2.0 Stick, When It's Plugged, Wifi Works Normally)



Has anyone encounter this problem, or solved it ?


(PS : I tried all three file systems : Mac OS, FAT32, and NTFS this happened, no matter what the file system is)


Oh and; sorry for my bad English

MacBook Air, OS X Mavericks (10.9), Macbook Air (Mid 2013)
  • SilverLanternMan Level 2 (170 points)

    take a look at these articles.



    Bluetooth: Unreliable wireless performance may occur when USB 3.0 external devices are close



    Using USB 3 devices on Mac computers FAQ


    I sometimes have difficulty with Wi-Fi or Bluetooth devices when USB 3 devices are attached to my computer.  What could be wrong?

    Some USB 3 devices, hard drives in particular, can generate radio frequency interference that can cause Wi-Fi and Bluetooth devices operating in the 2.4GHz band to have issues communicating with your computer. Do not place hard drives or other USB devices behind the rear of your Mac near at the hinge of your screen. The antennas for Wi-Fi and Bluetooth are located there, and USB 3 devices placed there may interfere with your wireless connections. See this white paper for more information.

  • modellista Level 1 (0 points)

    Hi yavuz,


    This exact problem is happening to me too with a 2013 Air.  When I use a USB3 hub, the wifi often stops working, in exactly the same way as yours - it still shows connected for a while, but no data flows.  If you disconnect and try to reconnect, it will show a timeout error.  An older USB2 hub doesn't cause the same problem.


    I've had intermittent wifi problems with the machine without the USB3 hub plugged in, but nothing repeatable, and the Apple store have tested the hardware with no faults found.  It's very annoying, you don't know when it's not going to work!

  • soujo Level 1 (0 points)

    Not sure if you've found your solution yet. If not, I might have an answer for you.


    I got my latest MacBook Pro just last week (running OS X Mavericks). WiFi working fine until last night. Since then I have had the exact problem you described: WiFi won't work when a USB drive is attached (but on the USB port on the left, not the right).


    I called Apple Support. The guy had never come across this problem but suggested a hardware reset which seems to have solved the issue. There are two resets. I did both. Steps are as follows:



    Shutdown computer, plug in the charger

    Press Option–Control–Shift

    Hold for 10 second

    Let go: charger light should go from Amber–Green–Amber



    PRAM reset:

    Shutdown computer

    Immediately after hitting startup button, hold down Command–Option–P–R until a second sound is heard

    Log in as usual


    Please let me know if it works for you.

  • Markus.S Level 1 (0 points)

    Same story and same problem with my Macbook Air (Mid 2013) and Mac OS X 10.10.2


    After I plug in a 64GB Verbatim Store 'n' Stay Nano USB 3.0 Drive the Wi-Fi is not working any more after about 5 to 10 minutes. When I remove the USB device, everything is working well again.


    Is there any fix by Apple meanwhile? Did anybody find a solution?


    Thanks a lot!

  • Markus.S Level 1 (0 points)

    Update 04/13/2015


    The funny thing: it seems it hapens only with the USB slot on the left side close to the MagSafe power connection. When I am using the USB 3.0 nano stick on the right side close to the Thunderbolt connection and SD-Card slot, everything is working well. It seems like a physical interference to the Wi-Fi module, or something like this. When that is really the reason, it would be a screw up by the Apple engineers like the antenne issue of the old iPhone with the metal antenna at the casing. I don't know but it is really annoying.