0 Replies Latest reply: Nov 20, 2013 11:40 AM by Ijmitchell
Ijmitchell Level 1 Level 1 (0 points)

Moderators feel free to move this to the appropriate place. I was having this problem for a while now. I'd connect my iphone and it would sync forever. I'd have to manually abort the sync. This led to stuff never actually syncing, and music disappearing from my iPhone. I did some Googling and came up with some solutions, and I tried one myself and it worked perfectly.

 

1. In iTunes, go to preferences, then go to Devices. Make sure the box is checked, that says "Prevent iPhones, iPods, and iPads from syncing automatically. Press OK.

 

2. If your iDevice is already connected, and already "infinitely syncing" you will have to manually stop the sync at this time. If not, connect your iDevice.

 

3. Still in iTunes, click on your device in the left-hand column, and go to the Music tab.

 

4. Uncheck the big box at the top that says "Sync Music"

 

5. Click the "Apply" button in the lower right-hand corner.

 

6. WAIT PATIENTLY. This will take a VERY long time. It WILL look like it is still hanging indefinitely, but I promise you, it is not. It took about 30 minutes for me, and the entire time it said "Finishing Sync." I thought it wasn't even going to work, but eventually, I noticed it started updating Podcasts, and a bunch of other stuff, presumably accumulated changes over the duration of this bug. I think at this time it is also file-checking your entire iDevice, presumably because of all those times you had to manually interrupt the synchronization.

 

7. After the iPhone fully completes its sync, Re-check the "Sync Music" box, and click Apply again. For best results, just pick your 1 or 2 favorite playlists to sync right now, then later tonight you can sync back your entire library, and leave it to sync as you watch TV or eat dinnner or what not... don't force yourself to sit through syncing thousands of songs if you don't have to, lol.

 

It is working for me after following these steps. I have NOT tried setting iTunes back to automatic syncs (undoing Step #1). I'd imagine that doing so will re-trigger the bug. You're welcome to try, and I will maybe try tonight when I am free, but for now, I'm actually late for class, but I really wanted to share this because I know this is a pretty big issue, especially if you love music like I do.


Windows 7