Skip navigation

Media clips "Missing" after upgrade to iMovie 10.0.1

2196 Views 9 Replies Latest reply: Jan 27, 2014 1:04 PM by Phil1111 RSS
David Strait Level 2 Level 2 (175 points)
Currently Being Moderated
Nov 24, 2013 7:33 AM

I upgraded from iMovie 9 to 10.0.1 yesterday. After the upgrade, I got a message saying "Some of your projects refer to media that is not available." Those projects with missing media show "ghost clips" on the timeline with transitions, titles, etc., but no actual video. Only about 10% of all my projects have this problem. The video clips exist in the iMovie 9 library and still works fine when launched in iMovie 9. Oddly, the clips also exist in the upgraded iMovie 10 library and are stored in the correct project folder within the "Original Media" folder.


When I click on the "Ghost Clip" in the timeline, there is a message in the viewer that says "Missing File.... FILENAME is missing. Try Reimporting the original source media." I tried to re-import the clips, but it apparently did nothing. I deleted the new iMovie 10 library, then upgraded to iMovie 10 a second time, but the same projects still had the problem. Another person in the forum had a similar problem but found that his "missing" media did not have a valid file extension. He corrected his problem by adding the extension (my extensions are OK). Others had a similar issue because their media was stored in iPhoto (mine isn't).


My current  "solution" is to keep iMovie 9 running and have dual libraries, but I fear the day when iMovie 9 no longer functions with a new Mac OS update. Does anyone have suggestions how to "reconnect" my media to the projects?




  • kriskress Level 1 Level 1 (0 points)

    Same exact problem. So annoying. With 9, you could click the little yellow error triangle and reconnect it at least. Now I can't even click that thing, let alone reconnect it.


    Also, in the older version of iMovie, this sometimes happened if you moved the editing location of the files somewhere else, but all you had to do was put them back and re-launch and you were good to go. Now I can't do that either.



  • Fuffkin Level 1 Level 1 (0 points)



    On upgrade half the clips are missing. I can still use the old version of iMovie but under Mavericks it appears unstable and is now always crashing.


    This ungrade debaacvle is very un-Apple.



  • CoreForce Level 1 Level 1 (40 points)

    Have the same issue, others as well. See discussion here:

    Seems to be related to Media on external drives.

    I'm lucky I can still use iMovie 9.

  • Fuffkin Level 1 Level 1 (0 points)



    Thanks for the link, but all my files are local, there are no external drives.


    I'm between a rock and a hard place: iMovie 9 seems unstable under Mavericks and iMovie 10 has lost half the files. Short of rolling back from Mavericks I'm stuffed - and I desparately need to finish this project.


    This is the very type of problem I switched to Apple to avoid. They've upgraded their own software and OS and left a lot of people hanging out to dry. It's the sort of thing I expect in the Windows / Microsoft world. Not Apple.



  • Phil1111 Level 1 Level 1 (0 points)



         I experience the same issue, although previous version of imovie is able to locate clip in finder. I would expect an easier fix from apple than having to redo all links of my on-going projects. My current workaround is to carry on using previous version for on going projects and to start new projects in the new version of iMovie.


    Best Regards,




More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.