4 Replies Latest reply: Nov 28, 2013 11:16 AM by léonie
Michael Abel Level 1 Level 1

Just installed Aperture 3 from a disc to my brand new MacBook Pro, but it says it is unable to launch this version (3.2.3)?

How can I upgrade?


MACBOOK PRO (RETINA, 15-INCH, LATE 2013), Mac OS 9.0.x
Solved by léonie on Nov 28, 2013 7:01 AM Solved

Are you sure about "Mac OS 9.0.x"? Or is it rather Mac OS 10.9.x?

 

If you are running MacOS 10.9 Mavericks, then Aperture 3.2 is no longer supported. Upgrade immediately to Aperture 3.4.5; you can download the installer from the Apple Support page:  Aperture 3.4.5  http://support.apple.com/downloads/#Aperture%203.4.5

 

After running the installer, launch Aperture and enter your registration number, and then sign into the AppStore to upgrade to Aperture 3.5.1.

 

The App Store will convert your previous licence to an AppStore licence, bound to your AppleID, so be sure to sign into the AppStore with the AppleID you are using to buy and upgrade software.

 

Regards

Léonie

 

One more thing - if you are not living in the United states -  in some countries, e.g., Germany, Scandinavia, people had difficulties to find the 3.5 update at the App Store. It was necessary to set the primary lauguage to English and the region to U.S. in the System Preferences "Language&Region" panel. If you are having similar problems, try to change the language and region and reboot, before trying to open the updates page in the AppStore.

  • léonie Level 10 Level 10
    expertise.photosformac
    Photos for Mac

    Are you sure about "Mac OS 9.0.x"? Or is it rather Mac OS 10.9.x?

     

    If you are running MacOS 10.9 Mavericks, then Aperture 3.2 is no longer supported. Upgrade immediately to Aperture 3.4.5; you can download the installer from the Apple Support page:  Aperture 3.4.5  http://support.apple.com/downloads/#Aperture%203.4.5

     

    After running the installer, launch Aperture and enter your registration number, and then sign into the AppStore to upgrade to Aperture 3.5.1.

     

    The App Store will convert your previous licence to an AppStore licence, bound to your AppleID, so be sure to sign into the AppStore with the AppleID you are using to buy and upgrade software.

     

    Regards

    Léonie

     

    One more thing - if you are not living in the United states -  in some countries, e.g., Germany, Scandinavia, people had difficulties to find the 3.5 update at the App Store. It was necessary to set the primary lauguage to English and the region to U.S. in the System Preferences "Language&Region" panel. If you are having similar problems, try to change the language and region and reboot, before trying to open the updates page in the AppStore.

  • Michael Abel Level 1 Level 1

    Once again léonie, you've saved the day..

    Problem solved!

     

    Thanks a lot!

  • Michael Abel Level 1 Level 1

    - and thanks again for the tip on changing the language..

    Probably wouldn't have figured that one out by just keep clicking 'till my fingers bled..

  • léonie Level 10 Level 10
    expertise.photosformac
    Photos for Mac

    You are welcome, Michael!