8 Replies Latest reply: Apr 13, 2015 7:04 PM by Mattelfesso
Longknife23 Level 1 (0 points)

After upgrading to Maverick, I find I can no longer download PDF files.  I have tried to export to PDF, Save as PDF and Print to PDF and each time it places a Zero Byte file on my desktop, but no PDF file.  I now have to use Firefox to get PDF files. 


Has anyone else experience this?

MacBook Pro with Retina display, OS X Mountain Lion (10.8)
  • Linc Davis Level 10 (192,599 points)

    Back up all data.


    If Adobe Reader or Acrobat is installed, there should be a setting in its preferences such as Display PDF in Browser. I don't use those applications myself, so I can't be more precise. Deselect that setting, if it's selected. Otherwise do as follows.


    Triple-click anywhere in the line of text below on this page to select it, the copy the selected text to the Clipboard by pressing the key combination command-C:

    /Library/Internet Plug-ins


    In the Finder, select


    Go Go to Folder


    from the menu bar, or press the key combination shift-command-G. Paste into the text box that opens (command-V), then press return.


    From the folder that opens, remove any items that have "Adobe" or “PDF” in the name. You may be prompted for your login password. Then quit and relaunch Safari, and test.


    The "Silverlight" web plugin distributed by Microsoft can also interfere with PDF display in Safari, so you may need to remove it as well, if it's present. The same goes for a plugin called "iGetter," and perhaps others.


    If you still have the issue, repeat with this line:

    ~/Library/Internet Plug-ins


    If you don’t like the results of this procedure, restore the items from the backup you made before you started. Relaunch Safari again.

  • Longknife23 Level 1 (0 points)



    Thanks for the information.  However, I am somewhat confused about what this accomplishes.  Does this procedure turn off Adobe Reader in Safari.  If so, what should I use in lieu of Adobe Reader?

  • Linc Davis Level 10 (192,599 points)

    Does this procedure turn off Adobe Reader in Safari.




    If so, what should I use in lieu of Adobe Reader?


    The built-in PDF viewer.

  • Jack_Mac Level 1 (0 points)

    I had the same problem and this solved it.  Now PDFs open in Preview and save normally.  Thank you!

  • Stephen Trowell1 Level 1 (0 points)

    I had the same problem, which was very frustrating because I have a work and a home computer both running Mavericks and it was only happening on the work computer.


    The solution that finally worked for me was to open Preferences in Safari, go to the Security tab, and uncheck Allow plug ins.  I am guessing that this disabled the Adobe plug-in which had been causing all the trouble.  Since I don't have any other plug-ins, it wasn't a problem for me.

  • HeikoV Level 1 (15 points)

    Thanks Linc Davis! Works for me. I should have known better than click yes to install that Acrobat thing.

  • Dalymuse Level 1 (0 points)

    Thanks, Linc. This worked, but now I can't open the PDFs in Safari.  I went over to Adobe's website looking for help, and their wasn't any.  You or anyone else have any ideas? 

  • Mattelfesso Level 1 (85 points)

    I have used Schubert|it's PDF Browser plugin for years (http://www.schubert-it.com/pluginpdf/), as it makes downloading easy, shows bookmarks in a sidebar, and allows users to navigate hyperlinks embedded in a PDF. 


    However, in Yosemite I needed to enable the plugin in Safari > Preferences > Security > Internet plug-ins: √ Allow Plug-ins. Website Settings...PDF Browser Plugin (choose sites to allow)


    Similarly, you need to enable the Adobe PDF Viewer plugin that comes with Adobe Reader if you prefer to use that plugin. The plugins are located in /Library/Internet Plug-Ins/.  To avoid conflicts you should only have one PDF viewer plugin installed here at a time, and discard old versions. Adobe's instructions explain the same thing: https://helpx.adobe.com/acrobat/using/display-pdf-browser-acrobat-xi.html