5 Replies Latest reply: Dec 4, 2013 9:07 AM by Nordic Skier
sparky201 Level 1 (0 points)

I am trying to reset my linksys e2500 wireless router and when i run the disc it tells me that I am not up to date.  Is this router not compatible with Mavericks??

MacBook Pro, OS X Mavericks (10.9)
  • arthur Level 5 (5,035 points)

    You probably don't need the disk. It's been a while since I had a Linksys (I got tired of all the crappy routers I had and finally bit the bullet and got an Airport Extreme. Way better. I have a whole drawerful of crappy routers, mostly Linksys). There is a reset button on the router itself. Routers generally run through your browser in terms of settings. The disk and the Linksys software on it are probably incompatible with Mavericks, but the router itself probably is.

  • Csound1 Level 8 (46,335 points)

    The router is compatible but the software is not, and you don't need the software.

  • tbirdvet Level 4 (2,845 points)

    I have this router and no issue with Mavericks.  I only use the web based interface (no disk)

  • sparky201 Level 1 (0 points)

    I just spent an hour with Cisco support and they had me reset my IP address, etc.  Problem solved.  Thanks!

  • Nordic Skier Level 1 (0 points)

    Am using Mac Pro 5,1.


    The drop outs to internet happen when connected to a DSL modem via my Asante router.  All connections are ethernet; not using wireless.


    When I connect directly via ethernet to my Qwest DSL modem, and bypas the router, no problem.


    Drop outs while Safari is open, or Google Chrome is open, can occur anytime. If Google Chrome and Safari are both open at the same time, internet dropout occurs for both simultaneously.  They occur after waking from sleep also.


    I can get back internet connectivity in both Chrome and Safari by unplugging the DC power to the Asante router for 5 seconds, and plugging the power back in; internet connectivity resumes instantly in both Chrome and Safari.


    So the problem is not isolated to Safari.


    The problem seems isolated to my Mavericks install completed yesterday because:


    This same Mac Pro running Win 8.1 from a separate SSD and separate boot to Win 8.1 through the router does not have the problem.


    My tenant downstairs running Win 7 through the router does not have any connection problems.


    There were no internet drop outs when connected to DSL modem via this same router when I ran Mountain Lion.


    Sparky, can you describe a "step-by-step" on how you reset your IP address, etc?


    Is this a "handshaking problem" between Mavericks and my router?


    Do others have suggestions for solution paths to try?


    Will report back right away.


    Thank you.