Previous 1 2 Next 15 Replies Latest reply: Jan 25, 2014 10:35 AM by LowLuster
Longtallsally28 Level 1 Level 1 (0 points)

Hey Apple Community I really need your help, I am in finals and my MBP just failed I need this fixed as quick as I can or my grades are doomed!


To lead I am a pretty experienced mac guy, I have tried everything in my arsenal, scoured the internet and spent days trying to fix this but I am stumped. I treat my MBP like my pride and joy! I am going to try and be very descriptive so you all know exactly where I am at, makin' it a little bit easier for all of us.



-Mid-2012 - 13"

- i7 Processor

-128 GB SSD (Apple installed)

-8 GB Ram

-Apple SSD SM128 E


The Issue:


- MBP boots with the grey folder with a question mark

-So I booted with Installer Disk, opened Disk Utility, Partioned it, 1 Partition, Options: Guid, Mac OSX Extended Journaled, and the SSD hung on the formatting

-So I waited and was provided with an error could not format the disk

-So I plugged in my Portable HDD, which I use for Time Machine, and attempted to restore from a back-up, however after choosing my portable HDD and I go to choose the install disc my SSD is not available to select for restoring from a Time Machine Backup

-Restarted the MBP and tried to format with Disk Utility again and this time it worked, so went to install fresh OSX from installer disc and at the VERRRYYY end it said that the computer needed to be restarted and the install could not be completed

-So I had a new SSD that I purchased at a great price, brand new, switched them out real quick, did the disc utility and all of the above, still no success.

-* If I ever got it to format the SSD, after the computer was restarted no matter what the name of the partition was, it is reverted back to Disk0s1.

-So scouring the internet I read and thought to repair the permissions on my disk but every time I attempted to repair the drive there was an error. I tried numerous times and the error switched between, Error 1 and Error 3.

-So again not giving up, I hooked up my SSD to my Mac Pro and reformatted and repaired the disk permissions for the SSD. Everything checked back okay and the Apple SSD SM128 E was properly formatted and set up to be thrown back in my MBP and work.

-However, upon replacing it back in my MBP it did not show the partition on my disk, and once again said Disk0s1.

-Finally, I tried the same previous 2 steps with the other SSD I had that was new (Is compatible with Mac for the record) and still no such luck.


The Question:


#1) Why does the computer not recognize SSD partitions? (i.e. revert to Disk0s1)


#2) Is there a possible component within the computer causing the continued failure? ( Is there a diagram showing all the components within the MBP?)


#3) What do I have to do to make this computer work?

I have no idea what to do anymore, I don't know what the heck happened to my $1,500 computer overnight but I need to fix it. I have spent too much time, energy, willpower, and most of all money to give up without it working.


Thank you guys so much for your help!



MacBook Pro (13-inch Mid 2012), OS X Mavericks (10.9)
Previous 1 2 Next