3 Replies Latest reply: Dec 6, 2013 9:56 PM by Bargahhf
CIAGP Level 1 Level 1 (0 points)

Just updated X-Code to 5.0.2 and now it crashes when I try to open an existing project. Seems to OK when a new project is started though.

 

What am I doing worng?


MacBook Pro, OS X Mavericks (10.9), 8 GB Ram
  • Mark Szymczyk Level 4 Level 4 (1,935 points)

    I doubt you're doing anything wrong. You might have an autosave problem where Xcode had trouble autosaving the project that keeps crashing. Go to the following location on your Mac:

     

    /Users/YourUsername/Library/Autosave Information

     

    Delete anything in there related to Xcode, such as files named Unsaved Xcode Document.xcworkspace. Restart Xcode and see if that fixes it.

     

    Another thing to try is to select the project file from the file, right-click, and choose Show Package Contents. See if any of the files in the package were modified recently. Any recently modified file would be a candidate for causing the crash. You could move the file out of the file package and see if this stops the crash, but this could cause major problems with your project. Don't move the project.pbxproj file out of the file package. Make a duplicate of your project file before you start moving files out of the project file package.

     

    The worst-case scenario is that your project file is corrupted. If you have a backup of your project, restore the backup. If you don't have a backup you'll have to create a new project and add the source code and xib files from the old project to the new project.

  • thewho2be Level 1 Level 1 (0 points)

    This helped me! I deleted Xcode, reinstalled, downloaded another version, rolled back to version 5.0.1 via TimeMachine etc. Nothing worked until I came across this. Thank you very much. Very good advice.

  • Bargahhf Level 1 Level 1 (0 points)

    I had the same issue then I found out all you have to do is to set the default view to List before opening any previous or new project and it worked, credit goes to this user below who found the solution.

     

    ahmedMac25

     

    I was able to resolve by workaround:

     

    1. Closed all open applications

    2. relaunch Finder

    3. run  sudo find / -name ".DS_Store"  -exec rm {} \;

    4. this removes all  .DS_Store old files on the computer

    5. launch finder and set default view to "LIST VIEW" as shown here:http://macs.about.com/od/usingyourmac/ss/Setting-Finder-Views-For-Folders-And-Su b-Folders_2.htm

    5. rerun the offending application and file chooser works