6 Replies Latest reply: Dec 19, 2013 5:09 PM by Gil Woolley
Gil Woolley Level 1 Level 1 (0 points)

I have a problem in Safari on an iMac running Mavericks. I select New Window. No window appears. If I select Window, then I can see at the bottom of the menu Untitled but no check mark. So I click on Untitled and a small window opens. then I have to click on the green button at top left and the window opens to what I expected all along. This problem is happening on my 2 year old iMac but not on my wife's 4 year old Mac Book Pro. The problem appeared as soon as I did the upgrade from Snow Leopard to Mavricks on the iMac. It has not happened on the Mac Book Pro. I tried Reset Safari and that did not help. I hate to unlock the iMac from its cable and then schlep it out to the car, over to the nearest Apple Store and in to the Genius Bar. Might have to but maybe someone has a flash of insight.


27" iMac, Mac OS X (10.6.4)
  • Carolyn Samit Level 10 Level 10 (95,950 points)

    Open a Finder window. From the Finder menu bar click Go > Go to Folder

     

    Type or copy paste the following:

     

    ~/Library/Caches/com.apple.Safari/Cache.db

     

    Click Go then move the Cache.db file to the Trash.

     

     

    Quit and relaunch Safari to test.

  • Gil Woolley Level 1 Level 1 (0 points)

    Carolyn,

     

    You are probably helping me close in on the solution but following the above steps did not alter the problem.

     

    While I was trying to execute your instructions, I discovered that my keyboard was no longer typing letters or commands in Safari nor Chrome nor Pages nor BBEdit. I had to solve that by rebooting the iMac.

     

    Then I came back to follow your steps again. I was able to locate the file and tow it to the trash (and empty the trash) with Safari turned off. But when I restarted Safari, the problem was still there. I tried that several times but no joy.

     

    Is the next step to delete more of Safari's cache files?

  • Carolyn Samit Level 10 Level 10 (95,950 points)

    Try troubleshooting Safari extensions and third party plugins.

     

    From the Safari menu bar click Safari > Preferences then select the Extensions tab. Turn that OFF, quit and relaunch Safari to test. If that helped, turn one extension on then quit and relaunch Safari to test until you find the incompatible extension then click uninstall.

     

    If it's not an extensions issue, try troubleshooting third party plug-ins.

     

    Back to Safari > Preferences. This time select the Security tab. Deselect:  Allow all other plug-ins. Quit and relaunch Safari to test.

     

    If that made a difference, instructions for troubleshooting plugins here.

  • Gil Woolley Level 1 Level 1 (0 points)

    Carolyn,

     

    I found that I had no Extensions installed!

     

    I went to plugins and there were a window worth. The one at the top was Adobe Flash. I think that I have that turned off. Well, I turned off all plug-ins. There are no extensions installed. Tried again. Same problem. No change. No improvement.

     

    No Joy;-(

     

    Software update reassures me that I have the latest Safari, It is Version 7.0 (9537.71)

  • Gil Woolley Level 1 Level 1 (0 points)

    Carolyn,

     

    Sorry, but your recommendations did not change the situation at all. So I dragged (almost literally) my iMac in to the Palo Alto Genius Bar today and Charlie spent about 40 minutes trying stuff which he was looking up on his iPad and which he knew from his own experience. He did try reloading Safari and that did not work! He tried actually many things which I could not as a layman understand but they were different. None of them helped. Finally he said that some 3 charcacter acronym was missing and I should take the computer home and reinstall the Mavericks operating system. He said that the missing (substitute that acronymn again) was necesarry for Safari to operate properly. So, I went home and did exactly what he did and Safari is now working properly in the sense that when I open it, it opens with a normal sized window as I would like.

     

    Maybe your suggestions would have worked in less severe cases but in my case, it took the trip back to the Genius Bar followed by a complete reinstallation of Mavericks.

     

    Thanks much for your help. I'll bet that in 9 cases out of 10, it would have solved the problem

     

    Gil

  • Gil Woolley Level 1 Level 1 (0 points)

    Carolyn,

     

    I eventually took the iMac in to the Genius Bar. They mumbled something I didn't quite understand about ACL and suggested that I go home and reinstall the Mavericks operating system. This of course took several hours but after that the problem is gone and has not reoccurred.

     

    Thanks for your suggestions. The effort is greatly appreciated.