Skip navigation

Problem with Finder on Mavericks

1585 Views 4 Replies Latest reply: Dec 6, 2013 7:59 PM by popluhv RSS
albert anton Level 1 Level 1 (0 points)
Currently Being Moderated
Dec 3, 2013 2:54 AM

Hello to everyone.

 

Since I updated to Mavericks, my Finder gets crazy: For example, when I try to open the Applications folder, Finder gets a lot of time to load the list. Same problem when I try to connect to my Mac Mini Server: Every two minutes, it stucks.

 

What's the problem with my finder?

 

PD: Sorry for my por english, it's not my native language...

iMac, OS X Mavericks (10.9)
  • Carolyn Samit Level 10 Level 10 (84,140 points)
    Currently Being Moderated
    Dec 3, 2013 3:38 AM (in response to albert anton)

    Might be Finder preferences are corrupted ...


     

    Open the Finder. From the Finder menu bar click Go > Go to Folder

     

    Type or copy paste the following:

     

    ~/Library/Preferences/com.apple.finder.plist

     

    Click Go then move the com.apple.finder.plist file to the Trash.


     

    Restart your Mac.

     

    If that didn't help, follow the instructions here >  Spotlight: How to re-index folders or volumes

  • popluhv Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 6, 2013 7:03 PM (in response to Carolyn Samit)

    similar problem: finder quits when I open it.

    I don't have ~/Library/Preferences/com.apple.finder.plist in my library/prefrences folder.

    I don't have google drive either, which seems to be most peoples' problem.

    I tried the re-index thing, but it didn't seem to do anything

  • Old Toad Level 10 Level 10 (113,175 points)
    Currently Being Moderated
    Dec 6, 2013 7:13 PM (in response to popluhv)

    don't have ~/Library/Preferences/com.apple.finder.plist in my library/prefrences folder.

    Yes you do.  You're probably looking in the wrong Library folder.  The one you want to be looking in is invisible by default:

     

    NOTE: In Lion and Mountain Lion the Home/Library folder is now invisible. To make it permanently visible enter the following in the Terminal application window: chflags nohidden ~/Library and press the Return key - 10.7: Un-hide the User Library folder.

     

    For  Mavericks, 10.9,  go to your Home folder and use the View ➙ Show View Options menu to bring the this window:

    Mavlibvis.png

     

     

    I have Finder problems a while back (brought on my my trying some hacks) and the only solution was to boot into the Recovery volume (boot with the Command + R keys held down)

     

    Recoveryvolboot.png

     

    and reinstall the system.

     

    Happy Holidays

  • popluhv Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 6, 2013 7:59 PM (in response to Old Toad)

    Worked like a charm. Thank You!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.