11 Replies Latest reply: Jan 18, 2015 3:47 PM by baltwo
richard g. Level 1 (0 points)

Is it possible to change the preset 1inch margins in a TextEdit Document?

MacBook Air, OS X Mavericks (10.9), TextEdit 1.9 (310)
  • HandyMac Level 2 (420 points)

    So far as I know, there is no way to change the one inch margins in TextEdit's Wrap to Page mode. However, you can create a document and specify the margins in Bean or iTextExpress (both based on TextEdit, and free), then save it (make sure to save as .rtf), and open it in TextEdit, and it'll have the margins specified in the other application. For instance, I have .rtf documents with 1/2-inch and 3/4-inch margins I made in one of those programs; when I double-click them they open in TextEdit and I use them as templates. (Note: Bean is "no longer being actively developed", but it still works fine, and this may be a good thing: Bean doesn't need any more features, it's fine as it is.)

  • Kurt Lang Level 8 (36,645 points)

    Go to the menu bar and choose File > Page Setup. Click on Paper Size and change US Letter (or whatever the current page size is) to Manage Custom Sizes. I created a new paper size named test and set the margins as seen here:


    Screen Shot 2014-05-17 at 2.16.49 PM.png


    Click OK to save your new settings. When you start a new document, click on Page Setup and choose your custom page setting.

  • PeteTB Level 1 (0 points)

    Hi Kurt,


    After reading lots of other threads saying that setting the margins was impossible, it was thrilling to read your solution. Everything worked fine except for the last step: when I chose the new custom page setting the margins etc were the same as the original default settings. Any ideas?



  • Kurt Lang Level 8 (36,645 points)

    Drat! I didn't test this all the way through. I found a place to setup margins in TextEdit and assumed it would work. Going the rest of the way through to actually printing something, you are correct. No matter what you enter for margins, they never change and TextEdit prints the same way it always has for both a plain text, and rich text file. And that is determined simply by how you have the text box stretched out on your screen.


    Below is exactly the same text. One with the text window on the screen stretched out wide, and the other made narrower and tall. Doing that changes the size of the text, and how it will print, as shown in the preview of each.


    Screen Shot 2014-12-19 at 8.42.23 AM.png


    Screen Shot 2014-12-19 at 8.42.41 AM.png


    TextEdit continues to be the weirdest app in the world when it comes to printing anything.

  • baltwo Level 9 (62,215 points)

    Try this:


    In TextEdit is is reasonably easy to change the margins to nearly anything you want-- down to the very edge of the paper. The other people who responded to your question who said it couldn't be done, just don't realize how easy it is.


    First, open the file viewing the RTF codes

    • Open TextEdit.

    • Do a Command-O and look at the Open dialog box.

    • Select the file whose margins you want to change.

    • Check the "Ignore Rich Text Commands" option box.

    • Click "Okay".


    Second, change the margins RTF codes

    • In the header of the document you will see a line that specifies the margins. This line will probably being this way: "\margl1440". The "marg" refers to "margin", and the letters that follow it stand for the margin sides: "l" = left, "r" = right, "t" = top, "b" = bottom. I believe that 1440 equals 1 inch. So, 20 equals one pixel on a 72 dpi screen.

    • Change the numbers to your liking.

    • Reopen the document (without checking the "Ignore Rich Text Commands") and "presto": you've got your margins changed. Piece of cake.


    27" i7 iMac (Mid 2011) refurb, OS X Yo (10.10.1), Mavs, ML & SL, G4 450 MP w/10.5 & 9.2.2

  • Kurt Lang Level 8 (36,645 points)
    Piece of cake.

    They forgot to put a winky after that "simple" fix.


    I'll have to give it a try, though it'll be a couple of days now before I can do that.

  • baltwo Level 9 (62,215 points)

    It's something that I collected in February, but failed to include where I got it. Here's your winky:

  • PeteTB Level 1 (0 points)

    And then a month later ... Great stuff! Thank you for that simple solution.


    Ignoring the rich text commands, I've changed the left and right margins to 540: (\margl540\margr540\) but I can't see any references to the top and bottom margins (or header and footer). Do you know where I can find them?


    Thanks in advance,



  • baltwo Level 9 (62,215 points)

    Just add margt and margb to the list. Here's an example:



  • PeteTB Level 1 (0 points)

    Marvellous! Thank you very much.

  • baltwo Level 9 (62,215 points)