2 Replies Latest reply: Jan 26, 2014 6:31 AM by lununez
hexenrit Level 1 Level 1 (0 points)

I am having an issue with my imac getting keychain turned on for icloud.


Keychain appears to function normally on my iPad and iPhone4S - They are saving passwords in safari, etc.


I recently had an issue where I had to use my AppleID to reset my administrator password, and after that keychain ceased to function on my imac.


I followed the steps to set aside the old 'login' keychain, and created a new one one named Notharcus, which I have written down relevant password information for.  Then I went forward and used my computer normally and all seemed well until I went to some favored websites and noticed that passwords weren't saving.  I then did a little research and ended up setting up the screensaver/sleep mode password in order to autofill even when websites do not want autofill.  This step didn't work either, so I went into System Preferences, and opened up iCloud and noticed that Keychain was unchecked! However, when I attempted to check the box, it prompted me for my AppleID and then immediately popped up an error.


Screen Shot 2013-12-04 at 6.36.36 PM.png


The spinning 'busy' icon next to keychain continued until I closed the window.


When this happened, I then did some searching on the forums and I found

http://support.apple.com/kb/TS4644 - iCloud Keychain Trouble shooting - did not have an answer for me that I could find, although I tried several options that sounded close.


https://discussions.apple.com/message/23509286#23509286 was a thread that gave me hope of a simple fix, and the only thread i could find with my same error message.  The fix did not work however.

iPhone 4S, iOS 6.1.4