6 Replies Latest reply: Oct 29, 2014 9:31 AM by Benjamin Losch
CCSchool Level 1 Level 1 (0 points)

I have a pure Mac environment using smb for home folder shares. Mavericks clients and server 3.0.1. Multiple logins are enabled. Guest accessible is off on user home shares (I had this on to solve a similar issue in ML, does not help in Mavericks)

 

Users since the mavericks upgrade can login on any client fine and the home directory is mounted.  They can log out and log in on the same machine fine.  If a user logs out and another user tries to login at that machine, they can authenticate but the machine states that the home directory has been moved or disabled. If I reboot the machine it works fine.  Server indicates the connection to the home folder from the previous user is still active in File Sharing. It appears that the home directory is not completely unmounting - soon as I reboot the affected client, the share drops out/shows disconnected.  I have tried smb and AFP with the same results.

 

Has anyone else seen this?  For now, instead of logout I just have users reboot until this is solved.  I can't tell if this is a client problem or server issue.  I have not tried login in multiple users on different clients. 

 

Any input or suggestions appreciated.


OS X Server
  • Hector Castillo Level 1 Level 1 (20 points)

    Sam issue here, I had the same issue even with ML server, server app 2 and my 2 clients running mavericks, I upgraded server to Mavericks and server app t 3l and the issue still there, so makes me think that it is server app 2 and 3 compatability bug with mavericks clients, I did a fresh install on a client and keep getting same issues, as you described reebooting after network user logs out is what is making them to work fine, temporary workaround

  • bpierce Level 1 Level 1 (0 points)

    Same issue on clean install of Server 3.02.  After one network user logs in via client mac, others can't access their home folders and file sharing shows the first network user still connected to SMB share, tying up the shared folder of home folders.  The first user logging out does not disconnect the SMB share.

     

    Unless a fix is available that I've missed, I might try a workaround of putting each network folder in a different location since this home server only has a  handful of users.  Logging out between each user will not be popular here.

  • AMI289 Level 1 Level 1 (5 points)

    Same issue,

    With every version of Server 3 (currently using 3.1.1 and Apple still haven't resolved the issue).

     

    It's really annoying,

    This OS X Server seems such an amateur work, so full of bugs.

     

    It's ironic that MAVERICKS server has such major compatibility issues especially with MAVERICKS clients.

  • 3_chords_truth Level 1 Level 1 (0 points)

    thanks for this. I have exactly this issue and I've been thinking it is some problem with my setup....but it seems its more like a bug...

     

    I'm interested in your idea bpierce of having different locations for each user... would this simply be a separate user folder for each user...? I only need 6 users...do you think this will work..?

     

    How long will it take Apple to sort this.?

     

    Cheers

    Chris R

  • AMI289 Level 1 Level 1 (5 points)

    I've found a workaround for this.

     

    I'm not a native english speaker so I'll try my best to describe it as clearly as possible.

     

    I'm explaining the process, so It's a bit long to read, but you can just scroll to the bottom to get the script itself.

     

    Anyway,

    While bpierce's workaround might work for a small enviorment, but we have 400+ network users, so manually creating each home folder in a different location is not an option for us.

     

     

    After logging in as a network user, and then logging out, I've logged in as a local administrator.

    I then opened Terminal and typed 'df' to see a list of devices that are currently mounted.

    I've then noticed that the home folder for the network user I've logged out from, is still mounted.

    What I was interested is the last column, 'Mounted On', which had the network location of the network users' home directories.

    It has shown as /Network/Servers/MY.SERVER.NAME/Volumes/RAID (RAID is the name of the drive that all of our home folders are saved on)

    I've tried to manually unmount it using 'umount' command, but received an error saying "resource is busy".

     

    Which I guess is the problem we're facing,

    For somewhat reason, the OS is unable to 'unmount' the last network user, and therefore it is interuptting it from mounting a new user's home folder when trying to log in with a different user.

     

    Luckily for us, there is a 'force' command to the 'umount' ('umount -f') which is kinda similair to having a USB device connected to the computer, and just unplugging it without ejecting it, therefore, the system doesn't 'care' if it's in use.

     

    So I wrote an applscript (Finder->Go->Utilites->AppleScript Editor) that basically what it does is creating a script, on a 'neutral' directory (I've chosen the local /Users directory), that force the automount of that network drive, set that script executable, and then set it as a Logout Hook, meaning that the everytime a user is loging out, no matter if a network or a local user, the computer will run this script (Actually, as you'll see from my script, I've set it as a Logout Hook before I even created the file. But it works that way anyway), and then I've set this file hidden, so someone won't accidently delete it.


    I then saved this applescript as .app, so it'll be easily executable,

    And then I manually logged in to each computer as a local administrator, and run this .app.

     

     

    So far we haven't encounter any issues with it.

     

     

    Anyway, here is the script,

    You will probablly need to adjust it to your server mount point,

    If you just skipped to here, and don't know how to do it, you can read this post from the start, and you'll see how I've done it.

     

    Just copy-paste it to AppleScript Editor, adjust it to your server, and you're set to go.

     

     

    My Script:

    do shell script "sudo defaults write com.apple.loginwindow LogoutHook /Users/logouthook" with administrator privileges

    do shell script "echo $'#!bin/bash

    umount -f /Network/Servers/MY.SERVER.NAME/Volumes/MOUNT.VOLUME' > /Users/logouthook" with administrator privileges

    do shell script "sudo chmod +x /Users/logouthook" with administrator privileges

    do shell script "sudo chflags hidden /Users/logouthook" with administrator privileges

     

     

     

     

    Hope it'll help you as well guys,

     

    If you need further assistan, just post here.

     

    :-)

  • Benjamin Losch Level 1 Level 1 (25 points)

    v