5 Replies Latest reply: Aug 18, 2014 3:44 PM by BDAqua
DCox10 Level 1 Level 1 (0 points)

I am using OS X 10.5.8 and my ISP is Comcast. Recently, I have periodically received messages when I'm using Apple's mail program that Comcast's server has rejected the passwords for my email accounts. I waded through the wall of Comcast Level 1 techs telling me the problem is due to the Apple mail program but, as expected, none of them could explain why. In any case, I was eventually transferred to a Level 2 tech person in Comcast's Signature Support team. I explained the problem to the tech and he said he could fix it online but it would cost $49.00! The tech said the settings needed to be changed. What settings could he have referring to because all the settings, at least the ones I have immediate access to, are configured correctly. I have the correct ports set for incoming and outgoing mail, there are no typographical errors, the paaswords are correct etc. I have read previous responses to similar questions but I have tried all the suggested solutions prior to coming here. Any new suggestions? 


iMac G5, Mac OS X (10.5.2)
  • BDAqua Level 10 Level 10 (119,670 points)

    Check Keychain Assistant, see if there are duplicate Comcast mail entries, there should be one each for in & out.

     

    But if it's occasional, I'd put my money on Comcast's end or stale DNS entries.

     

    You may have multiple entries.

     

    Open Keychain Access in Utilities, enter the part after the @ sign in the search bar, hit enter

     

    The Password rejection can confuse people since it's a catch all meaning...

     

    This Password, Username, Authentication method... is not recognized on this Port to this Server, more than one entry in Keychain for each in/out entry, or a server end problem.

     

    If using a browser to login via WebMail works it's not Name or Password, but one of the other ones.

     

    The receiving email ports are:

     

    IMAP is port 143

    IMAP-SSL is port 993

    POP is port 110

    POP-SSL is port 995

    Outgoing ports are...

    SMTP and SMTP-SSL is on ports 25, 587 and 465. Port 587 has to be SSL, and port 465 is enforced TLS-wrapped and is generally used by Outlook users.

  • DCox10 Level 1 Level 1 (0 points)

    Thanks so much for your assistance! Greatly appreciated.

     

    I have one more oddly related email question, although this one is pertains to the iPhone 4s.

     

    I have three Comcast email accounts. I can receive and send mail from my iPhone 4s. On the third account I can receive but not send mail. Whenever I attempt to send mail using this account I receive a message notifying me the username or password is incorrect. The user name and password are, in fact, correct. Any suggestions?

  • BDAqua Level 10 Level 10 (119,670 points)

    Great news, thanks!

     

    I know nothing about iPhones, never even held a Cell Phone yet, & I don't see how this could be it, but tossing it out...

     

    Gmail send but not receive...

     

    Here are two steps that have come in handy in related situations

     

    1) login to gmail on your computer or device via a web browser

     

    2) once logged in successfully, go to this URL to unlock:

     

    https://www.google.com/accounts/DisplayUnlockCaptch

  • agin Level 1 Level 1 (25 points)

    Thanks BDAqua!!!!! I know this is a rather old discussion, but I just started setting up a new Mac. This has been vexing me for days. I followed Comcast's set-up instructions, but no matter how I changed the Comcast settings, nothing helped. When I checked the Keychain Assistant, I found multiple entries for Comcast, so I just deleted them all. When Mail started checking for new mail, it asked for my password, and when I entered it, everything worked!

  • BDAqua Level 10 Level 10 (119,670 points)

    Great to hear, thanks!