3 Replies Latest reply: Dec 5, 2013 8:44 PM by Linc Davis
SammiC43 Level 1 Level 1

We recently changed our home wi-fi's security from WEP to WPA2/Personal, I now have to open my wi-fi setting and click on the hotspot to join it instead of it automatically connecting. It does not ask me for the wi-fi password but a window always comes up asking if I want to join every time I return to my mac after leaving it in Sleep mode.

 

How can I make it automatically connect to my wi-fi without always asking for permission to join it?

I have OS X Mavericks Version 10.9


MacBook Pro (13-inch Mid 2012), OS X Mavericks (10.9)
  • leroydouglas Level 6 Level 6

    Try resetting the  SMC http://support.apple.com/kb/ht3964

  • Frank Caggiano Level 7 Level 7

    In the Network settings for WiFi click on the Advanced button and see if Remember Networks this Computer has Joined is set

  • Linc Davis Level 10 Level 10
    expertise.applications
    Applications

    Test after taking each of the following steps. Back up all data before making any changes.

    1. Make sure the network is on the preferred list by following these instructions. It's important to read the article carefully, as it's the starting point for any further efforts to solve the problem. If you skip any of the steps, the problem may not be solved.

    2. Follow the instructions in this support article under the heading "Symptom: The network connection drops unexpectedly."

    3. Make a note of all your settings for Wi-Fi in the Network preference pane, then delete the connection from the connection list and recreate it with the same settings. You do this by clicking the plus-sign icon below the connection list, and selecting Wi-Fi as the interface in the sheet that opens. Select Join other network from the Network Name menu, then select your network. Enter the password when prompted and save it in the keychain.

    4. From the Location menu at the top of the Network preference pane, select Edit Locations. A sheet will drop down. Click the plus-sign button to create a new location. Give it any name you want. In the new location, set up the Wi-Fi service with the same settings you used before. Click Apply and test.

    5. Launch the Keychain Access application. Search for and delete all AirPort network password items that refer to the network. Make a note of the password first.

    6. Repair permissions on the startup volume.

    7. Turn off Bluetooth and test.

    8. Reset the System Management Controller.

    9. Reset the PRAM.

    10. Reinstall OS X.