6 Replies Latest reply: Dec 16, 2013 7:56 AM by BDAqua
Number22 Level 1 Level 1 (0 points)

On my old Powermac G4 my Page Sset-up cannot be opened anymore.

I have some Appleworks 6.2.9 spread sheets with multiple pages, which I need to print on an Epson 580 Printer,

the Print command in the File pulldown asks to "use the Page Set-up first", but  if I pull it down and click on it, it says

the same thing and does not show any dialog.

 

Is "Page Set-up"  part of Appleworks, or part of the Epson Printer Software, or is it part of the OS?

 

I got all the original disks for all that software, but reinstalling the whole works would take days

(...and may cause something else to disappear that I might not have on disk)

 

Your help is appreciated.  


PowerMac, Mac OS X (10.4.11)
  • Klaus1 Level 8 Level 8 (46,490 points)

    It is part of the printer software. Might be worth reinstalling the printer driver, then repairing permissions.

  • BDAqua Level 10 Level 10 (120,375 points)

    Does Page Setup not work in Text Edit>File>Page Setup also?

     

    Might try these...

     

    First, Safe Boot , (holding Shift key down at bootup), use Disk Utility from there to Repair Permissions, test if things work OK in Safe Mode.

     

    Then move these files to the Desktop for now...

     

    /Users/YourUserName/Library/Preferences/com.apple.finder.plist

     

    /Users/YourUserName/Library/Preferences/com.apple.systempreferences.plist

     

    /Users/YourUserName/Library/Preferences/com.apple.desktop.plist

     

    /Users/YourUserName/Library/Preferences/com.apple.recentitems.plist

     

    Reboot & test.

     

    PS. Safe boot may stay on the gray radian for a long time, let it go, it's trying to repair the Hard Drive.

     

    And/or, reinstall the big 10.4.11 combo update...

     

    The combo update for PowerPC-based Macs...

    http://www.apple.com/support/downloads/macosx10411comboupdateppc.html

     

    Repair Permissions afterwords, reboot.

  • Number22 Level 1 Level 1 (0 points)

    Hello Klaus, thanks for the Help.  I reinstalled my Epson RX 580 Printer Software, then updated the drivers from the Epson Website.

     

    Page Set-up was still not working.

     

    So  I reinstalled Appleworks 6, then updated it to 6.2.9.  ( I got all the disks and saved all the Uppdate .dmg's)

    I have 4 built-in hard drives, the largest one split into 3 separate volumes one of which is Techtool's E-drive), 3 of them have more or less the same data on it for back-up, all but one have their own boot start.

     

    I had the same problem with all the drives. Each day I update Appleworks spreadsheets which have 4 pages, then save with new date.  I seldom need to print them, and never had any trouble doing so, until this time.

     

    I went back a few years and picked one of the dated spreadsheets, opened it, then tried Page-Set-up and it worked.  It did that several times until I had narrowed down to the first dated SS in which Page set-up did not work:  It was dated Oct 1, 2009.  All later sheets had the same problem no Page Set-up possible, all earlier sheets were not so affected.

     

    I made a copy of the last working SS, saved it as a template, erased all the data, then tried Page Set-up and it worked,  I copied the data from a later sheet into it, and saved to desk under new name.  I tried Print using PDF Print, then noticed that the old sheet I had used as template had only 3 Pages. 

     

    I had to add new cells to get my 4 Page system back.  But here was a new problem, I could print, but it would only print the old cell range from the 3 Page spreads.  There was no way to print sheet 4.  Even the extra cells in sheet 3 would not print.  Now that must be caused by Appleworks!  Or rather the Appleworks updates which had been all over the place in their last glory days.  (I had  tried to back-peddle trying with Appleworks 6 and Appleworks 5, even Clarisworks, well it did not work but Appleworks 6 files now add the extension  .cwk to all files - even though Preferences are set to "No Extensions" and I click on "No Extensions" while saving files.  The only way to get rid of these extension is to save the file, then highlight the name of the file

    in its folder, and change delete the extension from the file name.  If this file is then opened up and saved a under a new nme the extension is gone from the new file as well.)

     

    I just about gave up here.  I had checked all the disks with Disk Utility to verify Permissions, and check the Volumes.  Nothing was found.   I brought in the Techtool  and checked all the drives , and volumes:  nothing found.  I noticed here that my most actively used drive needed defrag, and so I used Techtool to defrag.  I tried the next day and discovered that the new 4 page spread sheet template would now print all pages!

     

    So now I know what to do If I need to print from an old spresdsheet that has no Page Seutp.  I simply copy its contents to my new 4 sheet template.   All my new sheets are now done using the new template.

  • Number22 Level 1 Level 1 (0 points)

    Hello BDAqua:  Thanks for trying to help, meantime I have found a solution the hard way, as described above in my answer to KLaus.  I am sure you valid points there with your advise, some of which I also had used, and some of which I may use next time if I get into trouble again.

     

    Thanks .

  • Klaus1 Level 8 Level 8 (46,490 points)

    Glad you got it fixed!

  • BDAqua Level 10 Level 10 (120,375 points)

    Good work, thanks for the report!