5 Replies Latest reply: Dec 14, 2013 7:09 PM by mende1
gracer15 Level 1 Level 1

Hi,

My current os x is 10.8.5 and I juts bought a printer which requires 10.4.11 - 10.6.x... does this means i have to downgrade?

 

Please help with what I need to do.


MacBook Pro, OS X Mountain Lion (10.8.5)
Reply by mende1 on Dec 14, 2013 6:33 AM Helpful

Welcome to Apple Support Communities

 

Where have you found that information? Check if your printer appears in this list > http://support.apple.com/kb/HT3669?viewlocale=en_US&locale=en_US

 

If it appears, your printer is compatible with your OS X version, so there's no need to downgrade. To add the printer, follow these steps > http://support.apple.com/kb/HT4670

All replies