3 Replies Latest reply: Feb 24, 2014 9:19 PM by benhuxham
pmonether Level 1 Level 1

For many months, Configurator was working very smoothly, but recently we've had many problems getting available codes redeemed while setting up iPad carts. This is the same for old and new purchases alike, the licenses are clearly available in the Apps listing of Supervise, but an error is returned saying a valid code cannot be found. In a typical Cart deployment, 18 iPads receive codes and 7 do not. Does anyone know what causes this and what is the best course of action to resolve. Is there some database corruption? I do have regular Time Machine backups of the Mac Mini, so restoring older records would be possible.


A couple of follow-up questions: if I restore to an earlier VPP record in Configurator, what happens to the codes currently deployed in classrooms when those iPads are unsupervised? Are there steps I should take in the restoring process?



Mac Mini w/ Mavericks

Configurator 1.4.2

Deploying to 3 carts of iPad 2s

Mac mini (Late 2012)
  • pmonether Level 1 Level 1

    Right, so no help there, so I tried following the directions in the Apple Support KB on the topic of Restoring Apple Configurator data. Good news: I have dozens of Time Machine backups; Bad news: I've not found a backup yet which doesn't have many VPP licenses checked out to iPads. What I need clearly is a pristine backup set with all purchased VPP licenses available. Failing that, and if I don't want to have to repurchase licenses, am I looking at scrapping the com.apple.configurator container and building it up from scratch again? Would be a bit of work, but certainly do-able. Any downsides to this approach?

  • pmonether Level 1 Level 1

    Continuing this conversation with myself here's what I found out. I'm posting this in the hope that a. it may be helpful to others, and b. others with more experience and knowledge may supplement or verify my notes.


    First discovery - rebuilding from scratch is not an option if you have VPP codes for paid apps that you can't afford to sacrifice. When I tried, all looked great in the rebuilding process - adding apps, importing spreadsheet codes - until I tried to deploy the codes onto iPads. It looks to me like even using the same Configurator app on the same system, the rebuild is treated as a new instance. (It is a new ~/Library/Containers/com.apple.configurator folder, after all.) The spreadsheet codes were previously associated with the earlier instance and therefore cannot be used - at least that is how it appeared to me. If anyone has a different understanding, please chime in.


    Second discovery - locating a Time Machine backup as recent as possible with as many undeployed VPP codes as possible takes time, but in my case it was worth it - I didn't have to repurchase any licenses, and the restored data worked smoothly when deploying to iPads (3 different carts.) What takes time is that I had to do each restore and then look at the statuses on the paid apps, trying again if there were a low license count against paid apps. I'm not 100% certain this is necessary, or whether deployed licenses will be freed up when devices are unsupervised. (I know this is what usually happens, but I had unsupervised all my iPads before restoring - maybe not such a smart move, in which case I got lucky.)


    If anyone can point to a good resource on  how Configurator manages the license data, that would really help me understand what I'm seeing.


    Thanks in advance for any assistance.



  • benhuxham Level 1 Level 1

    Thanks for the info. It is appreciated. Unfortunately doesn't cover my problem, but it is close and I intially thought it did.